Closed Bug 1476818 Opened 2 years ago Closed 2 years ago

Wrong icon size is chosen for browserAction in the Overflow Menu

Categories

(WebExtensions :: Frontend, defect)

defect
Not set
normal

Tracking

(firefox61 wontfix, firefox62 wontfix, firefox63 fixed)

VERIFIED FIXED
mozilla63
Tracking Status
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- fixed

People

(Reporter: Oriol, Assigned: Oriol)

Details

Attachments

(3 files)

1. Install https://bugzilla.mozilla.org/attachment.cgi?id=8992085 in about:debugging
2. Right-click the browserAction and choose 'Pin to Overflow Menu'
3. Open the Overflow Menu

The 32px icon is used but the real size is 16px.

This makes my Tab Counter Plus icon look blurry in the Overflow Menu.
It seems 32px were used in bug 1272222 because back then the Australis menu really had 32px icons. This is no longer the case in Quantum.
Comment on attachment 8993180 [details]
Bug 1476818 - Choose right add-on icon size for browserAction in the Overflow Menu

https://reviewboard.mozilla.org/r/257986/#review265444

::: browser/components/extensions/parent/ext-browserAction.js:487
(Diff revision 1)
>      let icon16 = IconDetails.getPreferredIcon(icons, this.extension, 16).icon;
>      let icon32 = IconDetails.getPreferredIcon(icons, this.extension, 32).icon;

I wish there was some way to deal with the size than hard coding it.
Attachment #8993180 - Flags: review?(mixedpuppy) → review+
Keywords: checkin-needed
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ccee0cdce495
Choose right add-on icon size for browserAction in the Overflow Menu r=mixedpuppy
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ccee0cdce495
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Verified using FF 61.0.1 and Nightly 63.0a1 running on Ubuntu 18.04. 
The issue was not reproducible on 63, only on 61. - 08/14/2018
Status: RESOLVED → VERIFIED
Attached image 61.png
Attached image Nightly.png
You need to log in before you can comment on or make changes to this bug.