Closed Bug 147704 Opened 18 years ago Closed 8 years ago

Display problem: missing font rendering, without Xft

Categories

(Core Graveyard :: GFX: Gtk, defect)

PowerPC
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: vincent-moz, Assigned: blizzard)

References

()

Details

(Whiteboard: [mathml])

Attachments

(2 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.0.0+) Gecko/20020524
BuildID:    2002052323

The page at the given URL doesn't display correctly: random blank horizontal
spaces appear (i.e. some parts of the page are not visible).

Reproducible: Always
Steps to Reproduce:
1. Open the URL.
2. See what is displayed.
3. You may also scroll.

Actual Results:  Random parts (sometimes a thin horizontal line), mainly math
formulas but also normal text, are not visible. This changes when scrolling. The
page layout seems to be OK, though.

Expected Results:  The document should be correctly displayed.
Same problem with Mozilla 1.0.
-> changing component to MathML (otherwise it doesn't get appropriate 
visibility...)

Got a screenshot?
Assignee: Matti → rbs
Component: Browser-General → MathML
QA Contact: imajes-qa → ian
After some tests, the problem seems to only occur when using a VNC server.
Finally, perhaps a bug in the VNC implementation?
Attached file Output of xdpyinfo
Here's a new snapshot:

  http://www.vinc17.org/download/mathml5.png

You can see that this is a redraw problem, but I don't know why it occurs on
this page only. If I iconize the window and reopen it, nothing is redrawn in
the part of the window corresponding to the document, i.e. I can see what's
behind just like if the background were transparent.

When launching ksnapshot, I got the message:

Xlib:  extension "RENDER" missing on display "ay:1.0".

but nothing else wrong. I've attached the output of xdpyinfo in case Mozilla
requires specific extensions.
@reporter

Does it happens with newer builds?

You don't need the RENDER extension of your X ... but you can enable it for KDE
for faster output :-) See your XFree86.conf
I now use a Xft-enabled version and I no longer see any blank spaces problem.
The characters (when they exist) are incorrectly positioned, but I suppose that
this comes from bug 128153.
So ok ... discussion go over to bug 128153 and I'll close this bug as Invalide.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID
It wasn't invalid. There are two display problems: one probably due to bug
128153, and one that occurred in old versions of Mozilla (compiled without Xft
support, but I now always compile with Xft support). Contrary to the former
problem, the latter one (this bug) depended on how the page was redrawn (e.g.
when scrolling).
I've recompiled Mozilla (latest nightly source + make -f client.mk) without Xft
support. The bug is still there. So, I reopen the bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
hmm, maybe duplicate of bug 190278? (that bug is not really limited to hebrew,
contrary to what the summary says)
Vincent, do you use trunk or 1.4 branch?
Is it a problem with Xft on ppc or also with Xft on x86?
Summary: Display problem: blank spaces → Display problem: missing font rendering, without Xft
No, it is not a dup of bug 190278 (which is related to Xft): I get the problem
when I compile Mozilla *without* Xft support. So, it is *not* a problem with Xft
in my case.

I always use the trunk.
Now that I have a working configuration for Xft-enabled Mozilla, I can confirm
that this bug doesn't occur *with* Xft.
Over to Gfx:Gtk, then.
Assignee: rbs → blizzard
Status: UNCONFIRMED → NEW
Component: MathML → GFX: Gtk
Ever confirmed: true
QA Contact: ian → gtk
gfx/src/gtk/ has been removed on trunk.
Does this bug occur in a recent (cairo) trunk build?
Whiteboard: CLOSEME 07/01
There's still some blank (I get "a  η  b" instead of "a ≤ η ≤ b") and incorrect font display, but I don't know if this is the same bug. Tried with Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8.1.4) Gecko/20070508 Iceweasel/2.0.0.4 (Debian-2.0.0.4-0etch1). I'm going to attach a snapshot.
There are some troubleshooting tips and fonts at this URL that might help:
http://www.mozilla.org/projects/mathml/fonts/
Whiteboard: CLOSEME 07/01 → [mathml]
(In reply to comment #19)
> There are some troubleshooting tips and fonts at this URL that might help:
> http://www.mozilla.org/projects/mathml/fonts/

I did the font installation a long time ago (and I don't get the warning box saying that some fonts for MathML are missing).

Also note that this is a build *with* Xft (about:buildconfig says that --enable-xft is provided), though the problem occurred without Xft. But I no longer use builds without Xft. The problem I mentioned in comment #17 may be another (new) bug.
Product: Core → Core Graveyard
As far as I can tell, both the --enable-xft and --disable-xft modes have been completely superseded by cairo and freetype in the current source base.  The browser I'm typing this in (distro build of Firefox 8) renders the test page correctly.  Closing.
Status: NEW → RESOLVED
Closed: 17 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.