If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

table caption with align=left or right is not correctly rendered

RESOLVED DUPLICATE of bug 3166

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 3166
16 years ago
16 years ago

People

(Reporter: Jerry, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
See this testcase.

<TABLE border="1" align="center" width=200>
<CAPTION align="left">A test table </CAPTION>
<TR><TD>1.7<TD>0.002<TD>43%
</TABLE>

</HTML>

I know that table caption's align attribute is deprecated, but I think mozilla
should still support it for backward compatibility.

Comment 1

16 years ago
if you want to align text in a caption use text-align. Align should place the
caption on the left side of the table not on the top -> see html 4.0 spec. MS
implements the spec wrong.  We will sometime implement the correct align, and
then this MS bug will then be in our way. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

16 years ago
I dont agree to mark this as wontfix.
see html 4.0 spec,http://www.w3.org/TR/html4/struct/tables.html#adef-align-CAPTION


Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Duplicate of "Caption-align-left and caption-align-right do not work ('caption-
side')"

*** This bug has been marked as a duplicate of 3166 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.