Closed Bug 1478013 Opened 2 years ago Closed 2 years ago

Importance, Status and Platform section labels in show bug view are linked but not clickable

Categories

(bugzilla.mozilla.org :: User Interface, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: pascalc, Assigned: kohei.yoshino)

Details

Attachments

(1 file)

45 bytes, text/x-github-pull-request
Details | Review
Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0 ID:20180724100052

The status field (NEW, UNCONFIRMED…) in the status section at the top of bugzilla is a non clickable link in Firefox (works in Chrome), right-clicking and opening the link in a tab works, it also does not have the cursor:help icon when hovering the link.

I think that this is due to the unusual html there with a labe inside the a tag:
<a href="https://wiki.mozilla.org/BMO/UserGuide/BugStatuses" id="status-view-help-link" class="help">
        <label for="bug_status">Status:
        </label>
</a>
Assignee: nobody → kohei.yoshino
Importance and Platform links are also not clickable.
Summary: Status field in Status section is not clickable in showbug view → Importance, Status, Platform section labels are linked bug not clickable in show bug view
Summary: Importance, Status, Platform section labels are linked bug not clickable in show bug view → Importance, Status and Platform section labels in show bug view are linked but not clickable
Attached file pull request
Status: NEW → ASSIGNED
Merged to master.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Component: User Interface: Modal → User Interface
You need to log in before you can comment on or make changes to this bug.