Closed Bug 1478423 Opened 3 years ago Closed 3 years ago

Persistent blocked autoplay is ignored when user action is detected before page is fully loaded

Categories

(Core :: Audio/Video: Playback, defect, P3)

63 Branch
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox63 --- affected

People

(Reporter: aflorinescu, Unassigned)

References

Details

[Pre-requisites:] (default in Nightly 63)
media.autoplay.ask-permission = true
media.autoplay.default = 2
media.autoplay.enabled.user-gestures-needed = true

[Environments:]
Ubuntu 16.04 x64, Windows 10 x64, Osx 10.13
63.0a1 2018-07-25

[Steps:]
1. Navigate to https://edition.cnn.com/videos or https://youtube.com
2. Find and copy a direct video link from the step1 sites, open a new tab and paste the link.
3. Block (persistently) the autoplay. (double check in about:preferences#privacy - in block Auto play/Exceptions the site appears listed as blocked)
4. Open a new tab and paste again the link from step 2 and wait for the page to load without any action.
5. Open a new tab and paste again the link from step 2 and while the page is still loading click or right click somewhere on the page. (not on video control)

[Actual Result:]
4. The autoplay is blocked
5. The autoplay is not blocked.

[Expected Result:]
4. & 5. The autoplay is blocked.
Hi, Adrian,

The direct video link in step2 is like "https://edition.cnn.com/videos"? or you mean "XXX.com/xxx.mp4".

The result is not a bug, but our intend. (it seems our wording in the prompt is little confusion, we might change the wording later) 

When clicking "Don't allow" button, that means autoplay is not allowed before user activate the site by user gestures, such as mouse clicking, keyboard pressing (on anyplace in document). If the site already is activated by user, and then we would allow all media to autoplay.

In your case, step5, the page has been activated by clicking, so the autoplay would start.
Priority: -- → P3
See Also: → 1185052
This is our UX design, we don't have any plan to change this behavior recently, unless we decide to discard the design that is allowing sites to autoplay after user activates sites.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.