Closed Bug 1478669 Opened Last year Closed Last year

AddonRepository parsing does not match platform correctly.

Categories

(Firefox :: General, defect, P1)

50 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1476177

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

While building and example test case for about:welcome, I discovered that source urls for downloading extensions were not avialble.  It turns out that the AMO api returns "mac" for the platform and compares it against Services.appinfo.OS which returns "darwin" thus failing to find a compatible platform download.
Comment on attachment 8995238 [details]
Bug 1478669 - Fix addon data parsing for mac,

https://reviewboard.mozilla.org/r/259712/#review266718

we need to handle linux and windows too.
Attachment #8995238 - Flags: review?(aswan) → review-
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1476177
(In reply to Andrew Swan [:aswan] from comment #2)
> Comment on attachment 8995238 [details]
> Bug 1478669 - Fix addon data parsing for mac,
> 
> https://reviewboard.mozilla.org/r/259712/#review266718
> 
> we need to handle linux and windows too.

windows, linux and android match.  It's just darwin != mac.
(In reply to Shane Caraveo (:mixedpuppy) from comment #4)
> (In reply to Andrew Swan [:aswan] from comment #2)
> > Comment on attachment 8995238 [details]
> > Bug 1478669 - Fix addon data parsing for mac,
> > 
> > https://reviewboard.mozilla.org/r/259712/#review266718
> > 
> > we need to handle linux and windows too.
> 
> windows, linux and android match.  It's just darwin != mac.

heh, maybe not.  I tested on windows, it returned windows.  but maybe it is version specific.
You need to log in before you can comment on or make changes to this bug.