Multiple instances of Mozilla can't share a profile

VERIFIED DUPLICATE of bug 147160

Status

Core Graveyard
Profile: BackEnd
VERIFIED DUPLICATE of bug 147160
16 years ago
2 years ago

People

(Reporter: Robert Montante, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052309

If I start up a mozilla process, and then attempt to start up a second separate
process, the second process dumps me in the profile creation dialog box.  If I
try to reuse my current profile, I get the error message that the profile is in use.

This behavior was not the case in previous builds; is it now intentional?

I find it convenient and desirable to start separate processes, rather  than
always spawning new windows as children of the current process.  For example, I
have a (KDE) gui icon that starts "/usr/local/mozilla/mozilla" and another icon
that starts "/usr/local/mozilla/mozilla -mail".  (I checked, and the same
profile conflict occurs if I execute these two commands from a shell command line.)

Reproducible: Always
Steps to Reproduce:
1.Execute "${mozilla-path}/mozilla -mail"
2.Execute "${mozilla-path}/mozilla"
3.Attempt to reuse a profile (such as "default")

Actual Results:  I was told that I couldn't use the profile because it was in
use, and sent back to create a brand new one.

Expected Results:  Not go on to step 3 above, but just used the profile again.

grumble grumble grumble

Comment 1

16 years ago
Dupe of bug 147812 or bug 147160?
Yes.

The new behavior is intentional because the old behavior led to dataloss and 
profile corruption if both instances wrote to the profile.

*** This bug has been marked as a duplicate of 147160 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Verified as a dupe of bug 147160
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

16 years ago
Yes, I found the previous reports (sorry to clutter things up).

Still, couldn't the profile be reused in "read-only mode" somehow?
It seems I'm not the only one who finds it useful to start multiple
processes.  This new approach is not satisfactory.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.