Closed Bug 1479119 Opened 3 years ago Closed 1 year ago

Long images cut off after first page when printing

Categories

(Core :: Printing: Output, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1318856

People

(Reporter: jim.cicalo, Unassigned)

References

Details

(Whiteboard: [layout:print-triage:p1][frag2020])

Attachments

(1 file)

Attached image picture.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704194937

Steps to reproduce:

Load the attached PNG using the following code:

<!DOCTYPE html>
<html>

    <body>

        <img src="img/picture.png">

    </body>

</html>


Actual results:

When printing, only 1 page is produced containing only a portion of the PNG (which is quite long). The rest of the picture cannot be printed.


Expected results:

The PNG should have been printed over multiple pages, as can be seen when printing using Chrome.
Priority: -- → P3

This appears to print correctly if you load it in our ImageDocument container, which applies position: absolute to the img. In fact, just applying position: absolute to the original test case is enough to fix it:

data:text/html,<html><body><img style="position: absolute" src="https://bug1479119.bmoattachments.org/attachment.cgi?id=8995669" /></body></html>
Whiteboard: [layout:print-triage:p1]
Blocks: 1601429

Just adding display:block to the image works as well (or anything that makes it "block-level" really), fwiw.

I'm guessing the underlying issue here is likely the same as for bug 534182...

Status: UNCONFIRMED → NEW
Depends on: 534182
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Version: 61 Branch → unspecified
Whiteboard: [layout:print-triage:p1] → [frag2020]
Whiteboard: [frag2020] → [layout:print-triage:p1][frag2020]
No longer blocks: 1601429
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1318856
You need to log in before you can comment on or make changes to this bug.