Closed Bug 1479316 Opened Last year Closed Last year

Favicon is missing in responsive design mode

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 + fixed

People

(Reporter: soeren.hentzschel, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(1 file, 3 obsolete files)

Favicons are no longer shown with responsive design mode enabled and that's very annoying while developing websites. ;-)

STR:

1. open responsive design mode
2. open a website

Expected:

Favicon in tab

Actual:

Favicon is missing

I set the regressionwindow-wanted keyword because I am not sure about the regression bug. The tool mozregression shows 1472268 as first nightly without the correct favicon (but the patch from this bug has been backed out) and then there were the Nightly logo as favicon in responsive design mode for a few builds and since a few builds after this change there is no favicon at all in responsive design mode.
Summary: Favicon is missing in responsive design modus → Favicon is missing in responsive design mode
Could be related to recent work moving the favicon load to the content process
Sören, do you still have this bug in the latest nightly? Thanks
Flags: needinfo?(cadeyrn)
Yes, the favicon is still missing in the responsive design mode.
Flags: needinfo?(cadeyrn)
Thanks Sören, marking as blocking bug 1453751 per Marco's comment. Tracking too as this is a feature planned for 63.
Blocks: 1453751
Assignee: nobody → dtownsend
Definitely caused by bug 1453751 but right now I can't figure out how this used to work!
Prior to bug 1453751 responsive design mode relied on the parent process seeing
that no favicon had been loaded and so defaulting to the root favicon for a
site. This would have meant that on some occasions responsive design mode didn't
show the correct favicon for pages that specified their own. This change passes
all the link related messages to the parent so favicons, feeds and searches
should work correctly.
Comment on attachment 8998633 [details]
Bug 1479316: Pass through link related messages when in responsive design mode. r=jryans

J. Ryan Stinnett [:jryans] has approved the revision.
Attachment #8998633 - Flags: review+
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e367443dd417
Pass through link related messages when in responsive design mode. r=jryans
Backout by dvarga@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35b70105cbe3
Backed out changeset e367443dd417 fpor failure at devtools/client/responsive.html/test/browser/browser_favicon.js
Prior to bug 1453751 responsive design mode relied on the parent process seeing
that no favicon had been loaded and so defaulting to the root favicon for a
site. This would have meant that on some occasions responsive design mode didn't
show the correct favicon for pages that specified their own. This change passes
all the link related messages to the parent so favicons, feeds and searches
should work correctly.
Attachment #8998633 - Attachment is obsolete: true
Flags: needinfo?(dtownsend)
Attachment #8998921 - Attachment description: Bug 1479316: Pass through link related messages when in responsive design mode. r=jryans → Bug 1479316: Pass through link related messages when in responsive design mode. r=kmag
Prior to bug 1453751 responsive design mode relied on the parent process seeing
that no favicon had been loaded and so defaulting to the root favicon for a
site. This would have meant that on some occasions responsive design mode didn't
show the correct favicon for pages that specified their own. This change passes
all the link related messages to the parent so favicons, feeds and searches
should work correctly.
Comment on attachment 8998921 [details]
Bug 1479316: Pass through link related messages when in responsive design mode. r=kmag

J. Ryan Stinnett [:jryans] has approved the revision.
Attachment #8998921 - Flags: review+
Prior to bug 1453751 responsive design mode relied on the parent process seeing
that no favicon had been loaded and so defaulting to the root favicon for a
site. This would have meant that on some occasions responsive design mode didn't
show the correct favicon for pages that specified their own. This change passes
all the link related messages to the parent so favicons, feeds and searches
should work correctly.
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8fca282c5ffd
Pass through link related messages when in responsive design mode. r=jryans
https://hg.mozilla.org/mozilla-central/rev/8fca282c5ffd
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Attachment #8998938 - Attachment is obsolete: true
Attachment #8998958 - Attachment is obsolete: true
Thanks for fixing. I can verify that it works now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.