Closed Bug 1479575 Opened Last year Closed Last year

Reset browser region pref on Firefox 63

Categories

(Firefox :: Search, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox63 - verified
firefox64 --- verified

People

(Reporter: mkaply, Assigned: mkaply)

Details

Attachments

(2 files, 1 obsolete file)

Right now we only set browser region once on initial start of browser.

We should do it regularly.

At the same time, we should add a sanity check to make sure that if we receive a US region, it's in the US timezone.
Note that for uplift, we'll need to add the countryCode reset in as well.
Does this affect what the user actually sees? For example, if I went on a trip to say Germany, and happened to update Firefox whilst I was there, would I then be getting German region results for the next 6 weeks?
(In reply to Mark Banner (:standard8) from comment #3)
> Does this affect what the user actually sees? For example, if I went on a
> trip to say Germany, and happened to update Firefox whilst I was there,
> would I then be getting German region results for the next 6 weeks?

It would only affect region specific engines like ebay or Amazon.

So yes, it could be annoying. Right now we don't have a good way for a user to change their region,.
(In reply to Mike Kaply [:mkaply] from comment #4)
> (In reply to Mark Banner (:standard8) from comment #3)
> > Does this affect what the user actually sees? For example, if I went on a
> > trip to say Germany, and happened to update Firefox whilst I was there,
> > would I then be getting German region results for the next 6 weeks?
> 
> It would only affect region specific engines like ebay or Amazon.
> 
> So yes, it could be annoying. Right now we don't have a good way for a user
> to change their region,.

Should we check the user's timezone at each startup, and reset the region whenever the user's timezone changed?
> Should we check the user's timezone at each startup, and reset the region whenever the user's timezone changed?

Then we need to add a pref for timezone too. I'm wondering about just doing a region check at every startup.
(In reply to Mike Kaply [:mkaply] from comment #6)
> > Should we check the user's timezone at each startup, and reset the region whenever the user's timezone changed?
> 
> Then we need to add a pref for timezone too. I'm wondering about just doing
> a region check at every startup.

Each startup seems excessive, especially for users who open the browser to visit one url, close it, and reopen it next time they need to see a page. I think we should check at most once a day. Which makes me wonder if we should attach this to nsIUpdateTimerManager.
Priority: -- → P1
Doing a one time search region reset again.
[Tracking Requested - why for this release]: Needed to get Google searches in the right territory.

Doing a one time reset similar to what we did earlier versus implementing a full solution right now.
Comment on attachment 8996113 [details]
Bug 1479575 - Reset region on major upgrade and make sure timezones match.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: Some users have search in the wrong region and as a result an incorrect code is being used.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Go to about:config, change browser.search.region to a different region than yours.
Set browser.migration.version to a value less than 73

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Adds a pref rest during upgrade

String changes made/needed:
Attachment #8996113 - Flags: approval-mozilla-beta?
The patch in the uplift request is very different from the one attached previously to the bug and is not r+, is that the right patch for this bug or is this uplift request attached to the wrong bug?
Flags: needinfo?(mozilla)
Attachment #8996113 - Attachment is obsolete: true
Flags: needinfo?(mozilla)
Attachment #8996113 - Flags: approval-mozilla-beta?
Comment on attachment 9016006 [details]
Bug 1479575 - Search region reset.

Uplift request was for the wrong patch.

Sorry about that.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: 

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): 

String changes made/needed:
Attachment #9016006 - Flags: approval-mozilla-beta?
Comment on attachment 9016006 [details]
Bug 1479575 - Search region reset.

Taking for our last 63 beta as the patch is minimal, Mike please don't forget to land it on autoland please,  thanks.
Flags: needinfo?(mozilla)
Attachment #9016006 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
> Mike please don't forget to land it on autoland please,  thanks.

FYI, landing is queued.

https://lando.services.mozilla.com/revisions/D8269/23061/
Flags: needinfo?(mozilla)
This should be marked as Resolved Fixed right?
Flags: qe-verify+
(In reply to Bogdan Maris [:bogdan_maris], Release Desktop QA from comment #16)
> This should be marked as Resolved Fixed right?

it hasn't landed on trunk yet
Looks like it failed on autoland. I'll get a new patch up.
Chagned scope of this bug to just do a one off reset on 63.
Summary: Reset browser region on every major upgrade of the browser → Reset browser region pref on Firefox 63
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/b8b9cf480f41
Merge reset region pref patch for consistency r=Gijs
https://hg.mozilla.org/mozilla-central/rev/b8b9cf480f41
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
I have managed to reproduce the issue using Fx 63.0a1 buildID: 20180730221422.
The issue is verified fixed using Fx63.0b14 and latest Fx64.0a1 on Windows 10 x64, macOS 10.14.1 and Ubuntu 16.04 LTS. The browser region(browser.search.region) is now correctly re-set at startup if the steps in #comment10 are performed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.