Closed Bug 1479607 Opened 2 years ago Closed 2 years ago

Email just returned Error when trying to log in to Firefox

Categories

(Cloud Services :: Server: Firefox Accounts, defect)

61 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: steven.jestis, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704003137

Steps to reproduce:

I have had the issue with my registered email account for a while.  I setup my google email as a secondary, which worked.  Then I setup two factor authentication, and removed the backup email.  Now I get an error that says email was returned.  


Actual results:

Prompts me to enter my recovery code.  I enter it, and it still tells me email returned.


Expected results:

Should have logged me in.  I'm fine if you just delete the account, and I can recreate it.  Don't want the secondary Google to be my account, nor do I even want it to be my secondary!
Component: Untriaged → Server: Firefox Accounts
Product: Firefox → Cloud Services
I was still logged in at work.  That allowed me to disable two-step authentication (with DUO).

When I try to add back my firstname.lastname@gmail.com address a secondary email, I get "Failed to send email".  Since my firstname.lastname@outlook.com primary account does not get emails anymore for some reason it's only a matter of time before I am locked out of my account.  

So I deleted it.  Then I created it again, using my same firstname.lastname@outlook.com address.  At that point it wants me to go to outlook.com and confirm my account, but of course there is no email there to confirm (yes, I did check the junk email folder).  Interestingly, when I said do keep me up to date I got an e.mozilla.org email immediately on my outlook account but no confirmaiton link.  I went back to the Confirm your account, and said to resend the email.  It says "Your email was just returned".

So now I'm back to having an account, that is waiting for confirmation but I can't confirm it.
I went to outlook.com, and removed every entry in Blocked Senders under Junk email.  

Then I went to Safe senders, and added mozilla.org (firefox.com was already there).

I then sent the request for confirmation a final time, and it immediately reported that the email was returned.

I'm at a loss for what else to do.
Hi Steven, our systems recorded two bounces from your email address. I've cleared these bounces, could you please add accounts@firefox.com to your address book and try signing in again? Thanks!

+---------------------------+------------+---------------+---------------+
| email                     | bounceType | bounceSubType | createdAt     |
+---------------------------+------------+---------------+---------------+
| steven.jestis@outlook.com |          3 |             0 | 1522241086557 |
| steven.jestis@outlook.com |          3 |             0 | 1523995255075 |
+---------------------------+------------+---------------+---------------+
So much for adding firefox.com to the safe senders list in outlook.com.  I added accounts@ to both safe senders and my contacts list, asked for account verification to be resent, and it worked immediately.

Think I'll not mess with a secondary email or two-factor and leave well enough alone :-)

Thank you so much!  Issue resolved.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.