Closed Bug 1479758 Opened Last year Closed Last year

<kbd>⌘</kbd>+<kbd>↑</kbd> does not navigate the console input history when cursor at the beginning of the input

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox63 fixed)

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

(Whiteboard: [boogaloo-mvp])

Attachments

(1 file)

**Steps to reproduce**
1. Open the console
2. Evaluate `1 + 1`
3. Hit <kbd>⌘</kbd>+<kbd>↑</kbd>


**Expected results**

I navigate the input to the `1 + 1` entry

**Actual results**

The input stays empty
---

In old jsterm I used to use <kbd>⌘</kbd>+<kbd>↑</kbd> to quickly navigate between multiline entries (it goes to the very top of the input first, then the second stroke would navigate). We should ensure to handle this (as well as <kbd>⌘</kbd>+<kbd>↓</kbd> , since it does not work either).
Priority: -- → P2
Whiteboard: [boogaloo-mvp]
Makes sense. I've also thought about having a shortcut that would navigates through immediately regardless of cursor position. Know of any prior art for that?
That means more shortcut :)
I know gmail has vim-like binding to navigate through the message list (K-J), but I don't know if there are safe to use in the console. 
Also, that might confuse people used to vim by making them navigate the history when they want to only move the cursor up/down.
it may be plain better to have previous/next button to the right of the input so you can navigate more easily
could work very well with reverse search as well if people don't know how to cycle through results
Blocking on Bug 1479521 since the code changes quite a bit there.
Assignee: nobody → nchevobbe
Blocks: 1479521
Status: NEW → ASSIGNED
Priority: P2 → P1
No longer blocks: 1479521
Depends on: 1479521
Matches old-JsTerm behavior.

Depends on D2824
Comment on attachment 8999551 [details]
Bug 1479758 - Enable history navigation with Cmd/Ctrl ArrowUp/Down; r=bgrins.

Brian Grinstead [:bgrins] has approved the revision.
Attachment #8999551 - Flags: review+
Attachment #8999551 - Flags: review+
Comment on attachment 8999551 [details]
Bug 1479758 - Enable history navigation with Cmd/Ctrl ArrowUp/Down; r=bgrins.

Brian Grinstead [:bgrins] has approved the revision.
Attachment #8999551 - Flags: review+
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/93031405a2de
Enable history navigation with Cmd/Ctrl ArrowUp/Down; r=bgrins.
https://hg.mozilla.org/mozilla-central/rev/93031405a2de
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
You need to log in before you can comment on or make changes to this bug.