Add a preference (default on) for autoconfig sanboxing for first release

VERIFIED FIXED in Firefox 62

Status

()

defect
--
major
VERIFIED FIXED
Last year
Last year

People

(Reporter: shell, Assigned: mkaply)

Tracking

62 Branch
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62blocking verified, firefox63 fixed)

Details

Attachments

(4 attachments)

Since this is is a release only feature. All other builds (beta, dev edition, nightly, esr) will not sandbox Autoconfig.  Which means we have not had this ride "the trains".

The way it stands now, once it's done, it can't be turned off. We should use a pref to turn it on for a release or two just in case (similar to what we did with extension signing). 


Putting this behind a pref, default on is the low risk way to get land sandboxing autoconfig in 62.

* after a couple of Releases nothing major has happened, we can remove the pref.  
* If something goes wrong, it won't require a dot release to flip the pref to disable the sandboxing.
Posted patch First passSplinter Review
Simple change for the default and then display a deprecation message if parsing fails.

We're like to get an enterprise release notes page we can link to.
Comment on attachment 8998016 [details]
Bug 1479857 - Use pref for Autoconfig on release, off by default

Kris Maglione [:kmag] has approved the revision.

https://phabricator.services.mozilla.com/D2801
Attachment #8998016 - Flags: review+
Summary: Add a preference (default on) for autoconfig sanboxing for first 2 releases → Add a preference (default off) for autoconfig sanboxing for first release
tagged this for the 62 branch
Version: unspecified → 62 Branch
Status: NEW → ASSIGNED
Marking as a blocker so we will make sure to land this on beta before release.
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/68d89e639065
Use pref for Autoconfig on release, off by default r=kmag
https://hg.mozilla.org/mozilla-central/rev/68d89e639065
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Comment on attachment 8998016 [details]
Bug 1479857 - Use pref for Autoconfig on release, off by default

Approval Request Comment
[Feature/Bug causing the regression]: Use a pref to turn autoconfig off in beta/release
[User impact if declined]: None
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: No. This is a beta change and QA is ready to verify.
[Needs manual test from QE? If yes, steps to reproduce]: Yes, they have the information already (as part of test plan)
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Very low
[Why is the change risky/not risky?]: Adds pref around already turned off feature.
[String changes made/needed]:
Attachment #8998016 - Flags: approval-mozilla-beta?
Severity: normal → major
Flags: qe-verify+
Comment on attachment 8998016 [details]
Bug 1479857 - Use pref for Autoconfig on release, off by default

Let's verify in beta; should land for this week's beta 19 build.
Attachment #8998016 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Was this definitely the reason for the failure? I don't understand how this could cause any of these failure. This code does nothing if there is no autoconfig file.
Flags: needinfo?(mozilla)
That's really confusing.

It didn't happen in a try build.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad72156639084ad03ffe5ac9d25f6fe368e46f52

I'll run some local tests.
Flags: needinfo?(mozilla)
> Wow, Talos depends on non-sandboxed autoconfig:

Thank you for finding this!

It's a good thing we found this now. This would have broke when we moved to release and we would have had no idea why.

For now, I'm going to add the sandbox pref, but we have to find a solution to this before we remove the pref.
Posted patch Fix to talosSplinter Review
This is the talos fix.
Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0d5e2c4f446b
Enable Autoconfig sandbox for Talos. r=RyanVM
Comment on attachment 9002840 [details]
Bug 1479857 - Enable Autoconfig sandbox for Talos.

Ryan VanderMeulen [:RyanVM] has approved the revision.
Attachment #9002840 - Flags: review+
Landed on central.
Flags: needinfo?(mozilla)
This bug was covered by the overall manual testing efforts invested in the Sandbox AutoConfig feature. The uplift didn't break any existing or implemented functionality.

Marking this as verified fixed using Fx 62.0b20 on Windows 10 x64 and macOS 10.13.4.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Summary: Add a preference (default off) for autoconfig sanboxing for first release → Add a preference (default on) for autoconfig sanboxing for first release
You need to log in before you can comment on or make changes to this bug.