Closed Bug 1480036 Opened Last year Closed Last year

Allow scaling all MSG volume with a pref

Categories

(Core :: Audio/Video: MediaStreamGraph, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: padenot, Assigned: padenot)

References

Details

Attachments

(3 files, 2 obsolete files)

This is so that it's less annoying when running the tests locally.
Rank: 25
Priority: -- → P3
Comment on attachment 8996756 [details]
Bug 1480036 - Allow forcing a specific audio output device from a test.  r?pehrsons

Andreas Pehrson [:pehrsons] has approved the revision.

https://phabricator.services.mozilla.com/D2609
Attachment #8996756 - Flags: review+
I can't seem to be able to bend our test infrastructure to only set the loopback devices when needed. i'm going to adopt the following strategy:
- On Linux, we have loopback devices. Force their use in gecko, via a pref, so that we don't mutate/rely on the machine state. This means we can listen to music on a normal audio output device while running the tests.
- On other platforms, scale the volume. This means that we won't be hearing ear-piercing sine waves.
Attachment #8996652 - Attachment is obsolete: true
Attachment #8996756 - Attachment is obsolete: true
Attachment #8996652 - Attachment is obsolete: false
Attachment #8996757 - Attachment is obsolete: true
Comment on attachment 9001598 [details]
Bug 1480036 - Allow forcing a specific audio output device from a test.  r?pehrsons

Andreas Pehrson [:pehrsons] has approved the revision.
Attachment #9001598 - Flags: review+
Comment on attachment 9001599 [details]
Bug 1480036 - Stop relying on having the default device set globally. r?pehrsons

Andreas Pehrson [:pehrsons] has approved the revision.
Attachment #9001599 - Flags: review+
Comment on attachment 8996652 [details]
Bug 1480036 - Allow scaling all MSG volume with a pref. r?pehrsons

Andreas Pehrson [:pehrsons] has approved the revision.
Attachment #8996652 - Flags: review+
Pushed by paul@paul.cx:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3f99a091261f
Allow forcing a specific audio output device from a test.  r=pehrsons
https://hg.mozilla.org/integration/mozilla-inbound/rev/352e47aeafac
Stop relying on having the default device set globally. r=pehrsons
https://hg.mozilla.org/integration/mozilla-inbound/rev/f2dc5d8ac9ac
Allow scaling all MSG volume with a pref. r=pehrsons
Duplicate of this bug: 1477205
Duplicate of this bug: 1205816
Duplicate of this bug: 1301662
You need to log in before you can comment on or make changes to this bug.