coredump caused by getenv since missing header in mozglue/misc/TimeStamp.cpp

RESOLVED FIXED in Firefox 63

Status

()

defect
RESOLVED FIXED
11 months ago
11 months ago

People

(Reporter: changqing.li, Assigned: changqing.li)

Tracking

52 Branch
mozilla63
Points:
---

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.75 Safari/537.36

Steps to reproduce:

start polkit.service


Actual results:

report failed since segament fault.


Expected results:

service start success.

Here is the bug analyze:
1.  polkit depend on libmozjs-52.so.
2.  during startup polkit,  the call stack is here:
    JS::detail::InitWithFailureDiagnostic  ->mozilla::TimeStamp::ProcessCreation->getenv(MOZ_APP_RESTART)

3.  coredump happened during getenv since missing header stdlib.h,  int convert to char* cause coredump

4.  patch attached
Attachment #8996919 - Flags: review+
Keywords: checkin-needed

Comment 1

11 months ago
Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c617268ad37
Fix coredump caused by getenv. r=glandium
Keywords: checkin-needed

Comment 2

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0c617268ad37
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee: nobody → changqing.li
You need to log in before you can comment on or make changes to this bug.