Bustages on central with ERROR: Cannot find nodejs

RESOLVED FIXED in Firefox 63

Status

()

defect
P1
normal
RESOLVED FIXED
Last year
26 days ago

People

(Reporter: CosminS, Assigned: dmose)

Tracking

(Blocks 1 bug)

unspecified
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(1 attachment)

The tests on central: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=bd79b07f57a34e0d8fe01bdc3f34815d77c01444&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=success&filter-resultStatus=pending&filter-resultStatus=running&filter-searchStr=idx&selectedJob=191559102

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=191559099&repo=mozilla-central&lineNumber=1048

[task 2018-08-02T10:35:26.920Z] 10:35:26     INFO -  ERROR: Cannot find nodejs
[task 2018-08-02T10:35:26.947Z] 10:35:26     INFO -  *** Fix above errors and then restart with\
[task 2018-08-02T10:35:26.947Z] 10:35:26     INFO -                 "/usr/bin/make -f client.mk build"
[task 2018-08-02T10:35:26.948Z] 10:35:26     INFO -  client.mk:123: recipe for target 'configure' failed
[task 2018-08-02T10:35:26.948Z] 10:35:26     INFO -  make: *** [configure] Error 1
[task 2018-08-02T10:35:27.022Z] 10:35:27    ERROR - Return code: 2
[task 2018-08-02T10:35:27.023Z] 10:35:27  WARNING - setting return code to 2
[task 2018-08-02T10:35:27.023Z] 10:35:27    FATAL - 'mach build -v' did not run successfully. Please check log for errors.
[task 2018-08-02T10:35:27.023Z] 10:35:27    FATAL - Running post_fatal callback...
[task 2018-08-02T10:35:27.023Z] 10:35:27    FATAL - Exiting -1
[task 2018-08-02T10:35:27.023Z] 10:35:27     INFO - [mozharness: 2018-08-02 10:35:27.023792Z] Finished build step (failed)
[task 2018-08-02T10:35:27.023Z] 10:35:27     INFO - Running post-run listener: _summarize
[task 2018-08-02T10:35:27.024Z] 10:35:27    ERROR - # TBPL FAILURE #
[task 2018-08-02T10:35:27.024Z] 10:35:27     INFO - [mozharness: 2018-08-02 10:35:27.024239Z] FxDesktopBuild summary:
[task 2018-08-02T10:35:27.024Z] 10:35:27    ERROR - # TBPL FAILURE #

This looks like smthg caused by https://hg.mozilla.org./mozilla-central/diff/51795a3214ea/browser/config/mozconfigs/linux32/l10n-mozconfig
Flags: needinfo?(dmose)
Should be a straightforward fix; I'll have a patch in a bit.
Assignee: nobody → dmose
Flags: needinfo?(dmose)
Note that the reason I added node to the build toolchain here rather than disabling node in mozconfig is because I'm assuming that searchfox is likely to want access to NodeJS JavaScript parsing stuff (eg JSX parsers, so that it can parse non-transpiled code correctly).
Blocks: 1478995
Iteration: --- → 63.3 - Aug 6
Priority: -- → P1
gps, while these patches seem extremely likely to fix the problem, one thing that's not clear to me is why these jobs are failing at all, since node.configure still has allow_missing=True.  Any ideas?
Oh, perhaps it's that when NODEJS is set in the environment, that effective overrides allow_missing to be False.
Comment on attachment 8997035 [details]
Bug 1480392 - fix searchfox build failures caused by missing node toolchain,

https://reviewboard.mozilla.org/r/260992/#review268068

Yes, the presence of the environment variable always results in that value being used. It is up to downstream checks to verify the thing defined in the environment variable is actually used. Our policy (for better or worse) is to never ignore environment variables.
Attachment #8997035 - Flags: review?(gps) → review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/525db752c9be
fix searchfox build failures caused by missing node toolchain, r=gps
https://hg.mozilla.org/mozilla-central/rev/525db752c9be
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.