Closed Bug 1480459 Opened 4 years ago Closed 4 years ago

Some buttons from the "Type Controls" panel are not being focused after recently being spammed

Categories

(Toolkit :: Reader Mode, defect)

defect
Not set
trivial

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix

People

(Reporter: emilghitta, Unassigned)

References

Details

Attachments

(1 file)

Attached image focus.gif
[Affected versions]:
Firefox 63.0a1 (BuildId:20180801223951).
Firefox 62.0b13 (BuildId:20180730180407).
Firefox 61.0.1 (BuildId:20180704003137).
Firefox 60.1.0esr (BuildId:20180621121604).

[Affected platforms]:
Windows 10 64bit.
macOS 10.13
Ubuntu 16.04 64bit.

[Steps to reproduce]:
1. Launch Firefox.
2. Access the following webpage: https://en.wikipedia.org/wiki/Main_Page
3. Enter Reader Mode.
4. Open the Type Controls" panel.
5. Click the "+" button multiple times.
6. Press the "tab" key to toggle focus through the available buttons inside the panel.
7. Close the "Type Controls" panel.
8. Open the "Type Controls" panel.
9. Repeat step 6.

[Expected result]:
All the buttons are being focused successfully.

[Actual result]:
Some buttons are being skipped while focusing through the "Type Controls" panel.

[Regression range]:
I don't think that this is a regression (reproducible on older builds from 2016).

[Additional Information]
Please note that this is and Edge Case scenario.
For further information regarding this issue please observe the attached screencast.
This is because you have zoomed in to the maximum amount and thus the "+" button gets disabled. If you zoom out one level then you will be able to tab to the "+" button again.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.