Mozilla should display special icons for configured Drafts, Templates, Sent folders even when set manually on an IMAP server

RESOLVED DUPLICATE of bug 45395

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 45395
16 years ago
13 years ago

People

(Reporter: Scott Gifford (old account), Assigned: Henry Jia)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When I set my Sent folder to a specific IMAP folder in the "Copies & Folders"
tab of Mozilla, that folder isn't displayed with the special "Sent" icon.  Ditto
for "Drafts" and "Templates".  "Trash" is displayed correctly.

This is with 1.0RC3 (build 2002052309).

This seems similar, but not identical, to bug 132927.

Comment 1

16 years ago
As this works correctly with my IMAP account at web.de (no namespace 
advertised there and folders do not appear under the inbox like my main cyrus 
IMAP server account where this bug does occur) I think this is part of bug 
#27002. 
 
The reason is the special folders are not being found is because of namespace 
and server directory issues. 

Comment 2

16 years ago
Bug #132927 has nothing to do with this. That bug talks about new icons for 
shared folders. You're talking about the standard sent,draft and templates 
folder. That has to do like I said with the namespace issues in bug #27002 and 
bug #105385. 
 
 
(Reporter)

Comment 3

16 years ago
It's not a matter of it not finding the folders correctly; I've configured them
manually, and still the icons don't show up.

Maybe it is the same bug; if it starts working when those two are fixed, I'll
mark this WFM.
(Assignee)

Comment 4

16 years ago
This bug does exist. Mark new and change platform, OS to all.

The reason for this bug is the wrong interpreting of the canonical URI of these
specific folders.

Let me take care of this one, add Seth to CC list.
Assignee: sspitzer → Henry.Jia
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 5

16 years ago
Here is a workaround for those who really love this function. :-)

Method 1: Set the 'IMAP Server Directory' advanced setting to 'INBOX'(for Cyrus
and Courier IMAP server) or something like that

Method 2: Set the 'Copies & Folders' to other and select the folder

See also: http://bugzilla.mozilla.org/show_bug.cgi?id=27002#c106
Status: NEW → ASSIGNED
(Assignee)

Updated

16 years ago
Blocks: 160644

Updated

15 years ago
QA Contact: olgam → laurel

Comment 6

15 years ago
Is there somthing done on this bug, or is a workaround seen as satisfactory?
Apart from my opinion that it is not, since there is a junk-folder this
workaround does not work anymore, as when it is applied one gains the drafts
etc. icons but loses the junk-icon.

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 45395 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.