Closed Bug 1480706 Opened 2 years ago Closed 2 years ago

[clang linux32] TEST-UNEXPECTED-FAIL | LulIntegration.unwind_consistency | Value of: nTestsPassed == nTests

Categories

(Core :: Gecko Profiler, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files)

Attached file LUL log
Switching linux32 builds to clang fails gtests with:

TEST-UNEXPECTED-FAIL | LulIntegration.unwind_consistency | Value of: nTestsPassed == nTests

There is sadly not more in the output because of:
https://dxr.mozilla.org/mozilla-central/source/tools/profiler/tests/gtest/LulTest.cpp#12-15

This patch is enough to get going to reproduce the issue on try:
https://hg.mozilla.org/try/rev/bda9def26ee3d0808a87b5d0b9bdd035f3bd77b1

That builds Firefox with clang 6.0.1.

Attached is the LUL log I got on try after enabling DEBUG_LUL_TEST.
Note that building with clang requires apply the patch from bug 1480401.
Assignee: nobody → mh+mozilla
Attachment #8998133 - Flags: review?(jseward)
Comment on attachment 8998133 [details] [diff] [review]
Enable Frame-pointer chasing on x86

Note that that will only enable it for desktop x86(32)-linux.
If you want to also enable it for x86(32)-android, you'll need 
to throw in GP_PLAT_x86_android too.
Attachment #8998133 - Flags: review?(jseward) → review+
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/946dc9d537c0
Enable Frame-pointer chasing on x86. r=sewardj
https://hg.mozilla.org/mozilla-central/rev/946dc9d537c0
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.