Closed Bug 14808 Opened 21 years ago Closed 20 years ago

Highlight painting problems in text widget

Categories

(Core :: DOM: Editor, defect, P2, major)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 15901

People

(Reporter: dead, Assigned: kinmoz)

Details

Steps to reproduce:

1) Highlight all or a section of text in a text field (or the URL bar)
2) Type
3) Notice that the highlighted part does not appear to get erased as it should.

However, if you cause a repaint to occur (bring another window to the front and
then bring apprunner back to the front) the highlighted text will be gone.

This does not occur if you highlight the text and hit backspace or delete, that
seems to work ok.
Assignee: akkana → buster
The text widget isn't invalidating a big enough rect.  Pavlov's changes last
night to the gtk painting code (which made the UI *much* faster on Linux) to
repaint only what we're explicitly told to exposed this problem.

Perhaps Pavlov can comment further since he's more familiar with the details.
Assignee: buster → kin
Severity: normal → major
Priority: P3 → P2
Target Milestone: M12
akkana, thanks for the analysis.  sounds like a reasonably bad usability
problem.  It's only showing up on linux now, but I wonder if it might show up on
other platforms  as their rendering code is better optimized as pavlov has done
for linux.
Lets try to get this in for M12.
Accepting bug.
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
I fixed this lastnight. See bug 15901 for more details.

*** This bug has been marked as a duplicate of 15901 ***
verified in 10/18 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.