Closed Bug 14809 Opened 21 years ago Closed 20 years ago

Lose layout info after mousing over javascript mouseover images

Categories

(Core :: Layout, defect, P3)

x86
Other
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jrspm, Assigned: karnaze)

References

()

Details

Go to this page:  http://www.hazelden.org/conf/threads.dbm?Title=& Age=1

Now, mouse over any image in the header of the page except the first one (for some strange reason, the first image, the furthest left, does not affect this) and then pull the mouse back off that image.  All of a sudden, all table layout info is completely forsaken and the HTML is no longer held within the parent table.

The really strange this is, this is not totally replicable throughout the site.  The reason that is strange is that the header is an include file.  Exactly the same header and footer exist everywhere on the site in exactly the same way.  The only thing that would be different is the HTML content between the header and footer.  The header begins and outer Table tag which the footer closes. This is what keeps the site centered within the header and footer.  I know because I created the site.

I picked the above URL because it happens VERY consistently.  I am using Windows 2000 RC2.

Jake
Component: Javascript EngineLayout → Layout
Assignee: __UNKNOWN__ → rods
Hello, Rod, I reasigned this bug to you because you took some other layout
related bugs.  Bugzilla alowed multiple selects of components when I first
submitted it, so it was assigned to "_UNKNOWN_" and I figured that noone would
get any message about it existing unless I assigned it to someone, so I saw
your email and assigned it to you.
The URL you posted in the bug does not work for some reason. If you could attach
a simple test case, this would be a big help. The either I will take it or
reassign it to the right person.
Sorry, those extra URL parameters didn't need to be there + they copied wrong.
There was some weird spacing.  Anyway, the URL:
http://www.hazelden.org/conf/threads.dbm
will work just fine.  I haven't even attempted a simple test case because I
don't have a clue why this would happen.  If you browse through the site, you
will find that even with exactly the same mouseover script (all included in the
same header file on the entire site), it doesn't happen consistently on the
site as a whole.  I guarantee, however that the table reflow will be entirely
lost after moving the mouse over the header images and then pulling it off at
the URL I have provided.

Jake
Assignee: rods → karnaze
Chris, a table reflow issue to check out. Although I am not sure exactly what is
wrong after mousing over the images.
I just checked the page out in the last 2 nightly builds (ones from 10/19/1999
and 10/20/1999) and they don't seem to have this problem.  If you want to
reproduce the problem, look at it in older nightly builds or M10.  It was still
happening in M10.  Seems to be fixed now, however.  Don't know what fixed it,
but I'm glad someone did.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Marking worksforme based on latest comments.
You need to log in before you can comment on or make changes to this bug.