Closed Bug 1481322 Opened 3 years ago Closed 3 years ago

Videos start autoplaying after scroll up in Huffington post

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: eeejay, Unassigned)

References

()

Details

STR:

1. Go to a huffington post article like: 
2. The video at the top of the article does not autoplay. That is good.
3. Scroll down the page.
4. Scroll back up the page.

Result: Video starts playing.
Expected: Video should continue to be blocked.

The play() probably happens through a 'scroll' event that is "user initiated", but really feels random. I'm not sure how to fix this.
Hi, Eitan,

Do you click any button on the prompt which asks you whether you want to allow this site to autoplay?

Now the site could only be allowed to autoplay after 
(1) user clicks "Allow" in prompt
(2) user activates the page by specific user gestures (mouse click, keboard press)

Thank you!
Flags: needinfo?(eitan)
Autoplay is blocked on that site for me.

What I think is happening is that the video starts playing from a 'scroll' event handled that is considered user initiated.
Flags: needinfo?(eitan)
No, we don't support 'scroll' event as a user activation gestures [1].

If the video starts playing, it means that it is muted, volume 0, allowed by prompt or activated by user gestures defined in [1].
 
[1] https://searchfox.org/mozilla-central/rev/51268dcbdff0f6f4a5cff7986df0f616efc5bcfd/dom/events/EventStateManager.cpp#919
OK, so I am not sure how this happens. Did you try my STR above?
I can look into this more tomorrow too.
Yes, I has tried the STR in comment0, but the video didn't start.
Rank: 25
Priority: -- → P3
I still can't reproduce this issue on today's Nightly 64.0a1 (2018-09-13) (64-bit), so close this bug.
Please feel free to reopen this bug if you see the issue again.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.