Closed Bug 1481348 Opened Last year Closed Last year

Intermittent JavaScript Error: "Polling for changes failed: Server error 404 Not Found: "JSON.parse: unexpected character at line 1 column 1 of the JSON data

Categories

(Firefox :: Remote Settings Client, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: leplatrem)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=192309708&repo=mozilla-central

https://queue.taskcluster.net/v1/task/I6eqEZi6TWW6LSF0RLQ5Xw/runs/0/artifacts/public/logs/live_backing.log

8:26:55     INFO - TEST-PASS | browser/components/payments/test/browser/browser_total.js | Check unmodified total currency amount - "$2.00 USD" == "$2.00 USD" - 
18:26:55     INFO - Buffered messages logged at 18:26:55
18:26:55     INFO - Leaving test bound test_modifier_with_no_method_selected
18:26:55     INFO - Entering test bound test_modifier_with_no_method_selected
18:26:55     INFO - adding a basic-card
18:26:55     INFO - Console message: [JavaScript Error: "Polling for changes failed: Server error 404 Not Found: "JSON.parse: unexpected character at line 1 column 1 of the JSON data"." {file: "resource://services-settings/remote-settings.js" line: 717}]
18:26:55     INFO - remoteSettingsFunction/remoteSettings.pollChanges@resource://services-settings/remote-settings.js:717:13
18:26:55     INFO - async*notify@jar:file:///Z:/task_1533576206/build/application/firefox/omni.ja!/components/RemoteSettingsComponents.js:24:5
18:26:55     INFO - TM_notify/<@jar:file:///Z:/task_1533576206/build/application/firefox/omni.ja!/components/nsUpdateTimerManager.js:197:11
18:26:55     INFO - TM_notify@jar:file:///Z:/task_1533576206/build/application/firefox/omni.ja!/components/nsUpdateTimerManager.js:244:7
18:26:55     INFO - 
18:26:55     INFO - Buffered messages finished
18:26:55     INFO - TEST-UNEXPECTED-FAIL | browser/components/payments/test/browser/browser_total.js | [JavaScript Error: "Polling for changes failed: Server error 404 Not Found: "JSON.parse: unexpected character at line 1 column 1 of the JSON data"." {file: "resource://services-settings/remote-settings.js" line: 717}]
18:26:55     INFO - remoteSettingsFunction/remoteSettings.pollChanges@resource://services-settings/remote-settings.js:717:13
18:26:55     INFO - async*notify@jar:file:///Z:/task_1533576206/build/application/firefox/omni.ja!/components/RemoteSettingsComponents.js:24:5
18:26:55     INFO - TM_notify/<@jar:file:///Z:/task_1533576206/build/application/firefox/omni.ja!/components/nsUpdateTimerManager.js:197:11
18:26:55     INFO - TM_notify@jar:file:///Z:/task_1533576206/build/application/firefox/omni.ja!/components/nsUpdateTimerManager.js:244:7
18:26:55     INFO -  - 
18:26:55     INFO - Stack trace:
18:26:55     INFO - chrome://mochitests/content/browser/browser/components/payments/test/browser/head.js:onConsoleMessage:331
18:26:55     INFO - chrome://mochikit/content/tests/SimpleTest/specialpowersAPI.js:observe/<:385
18:26:56     INFO - waitForMessageFromWidget: paymentDialogReady
18:26:56     INFO - GECKO(6148) | ++DOCSHELL 000001E2F6443000 == 6 [pid = 6148] [id = {03178357-fb44-4043-9727-ffdc65613ccf}]
18:26:56     INFO - GECKO(6148) | ++DOMWINDOW == 14 (000001E2F6506400) [pid = 6148] [serial = 146] [outer = 0000000000000000]
18:26:56     INFO - GECKO(6148) | ++DOMWINDOW == 15 (000001E2E819E400) [pid = 6148] [serial = 147] [outer = 000001E2F6506400]
18:26:56     INFO - GECKO(6148) | --DOMWINDOW == 3 (0000025EBE523600) [pid = 7244] [serial = 116] [outer = 0000000000000000] [url = https://example.com/browser/browser/components/payments/test/browser/blank_page.html]
18:26:56     INFO - GECKO(6148) | [Parent 6148, Main Thread] WARNING: NS_ENSURE_TRUE(root) failed: file z:/build/build/src/layout/base/nsDocumentViewer.cpp, line 3544
18:26:56     INFO - GECKO(6148) | ++DOCSHELL 000001BFA566B800 == 2 [pid = 6536] [id = {93d44052-10eb-45b7-b3d2-e397f6ba2c02}]
18:26:56     INFO - GECKO(6148) | ++DOMWINDOW == 13 (000001BFA5627200) [pid = 6536] [serial = 181] [outer = 0000000000000000]
18:26:56     INFO - GECKO(6148) | ++DOMWINDOW == 14 (000001BFA7432C00) [pid = 6536] [serial = 182] [outer = 000001BFA5627200]
18:26:56     INFO - GECKO(6148) | ++DOMWINDOW == 15 (000001BFA7C0C000) [pid = 6536] [serial = 183] [outer = 000001BFA5627200]
18:26:56     INFO - GECKO(6148) | ++DOCSHELL 000001BFA7C72000 == 3 [pid = 6536] [id = {3b323304-a971-4f8a-84e9-47dae5a39039}]
18:26:56     INFO - GECKO(6148) | ++DOMWINDOW == 16 (000001BFA7C4B400) [pid = 6536] [serial = 184] [outer = 0000000000000000]
18:26:56     INFO - GECKO(6148) | ++DOMWINDOW == 17 (000001BFA8A1A000) [pid = 6536] [serial = 185] [outer = 000001BFA7C4B400]
18:26:57     INFO - Got paymentDialogReady from widget
Whiteboard: [webpayments] [triage]
Component: WebPayments UI → Remote Settings Client
Summary: Intermittent browser/components/payments/test/browser/browser_total.js | [JavaScript Error: "Polling for changes failed: Server error 404 Not Found: "JSON.parse: unexpected character at line 1 column 1 of the JSON data → Intermittent JavaScript Error: "Polling for changes failed: Server error 404 Not Found: "JSON.parse: unexpected character at line 1 column 1 of the JSON data
Whiteboard: [webpayments] [triage]
Duplicate of this bug: 1481734
Assignee: nobody → mathieu
Comment on attachment 9001719 [details]
Bug 1481348 - Prevent intermittent failures with fake RemoteSettings server r?glasserc

Ethan Glasser-Camp (:glasserc) has approved the revision.
Attachment #9001719 - Flags: review+
Thanks Ethan for your review.

I'm aware that the current patch is not entirely elegant. I'm going to be off for the next 2 weeks. If this issue becomes too annoying, we can land it as it is, and iterate later.

> Can you confirm that we don't expect any users to self-host RemoteSettings? If so, I'm OK with it. If not, I'm a little nervous about the test, because it could mask server misconfiguration.

Indeed, users that self-host remote settings could have some server configuration error masked.

Or for example, when using STAGE, changing the polling endpoint preference to a bad value would silently fail.
Duplicate of this bug: 1487448
Pushed by mleplatre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1cb35a652277
Prevent intermittent failures with fake RemoteSettings server r=glasserc
Flags: needinfo?(mcastelluccio)
https://hg.mozilla.org/mozilla-central/rev/1cb35a652277
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Flags: needinfo?(mathieu)
The bot keeps pinging here saying «Resolving this bug is a high priority» while the graph shows a drop :)

Eliza, could you please confirm that this is resolved?
Thanks!
Flags: needinfo?(ebalazs)
Yes, this is resolved, no failures in the last 7 days (5th-12th Sept).

The failures from Comment 19 are from the 4th of Sept, and this was fixed on the 5th of Sept.
Flags: needinfo?(ebalazs)
You need to log in before you can comment on or make changes to this bug.