Can't change event date, always resets to 30.12.0002. [RangeError: date value is not finite in DateTimeFormat.format()]

RESOLVED DUPLICATE of bug 1503731

Status

RESOLVED DUPLICATE of bug 1503731
5 months ago
2 months ago

People

(Reporter: yusufaktepe, Unassigned)

Tracking

Lightning 6.2

Details

(Whiteboard: [datetime-issue-6.2])

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
Created attachment 8998092 [details]
Screenshot_07-08-2018_08-25-15.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704003137

Steps to reproduce:

Right click on a date > New Event > Try to change Start or End date


Actual results:

I can't change the date and it's always returns to 30.12.0002
(Reporter)

Updated

5 months ago
Component: Untriaged → Provider: GData
Product: Thunderbird → Calendar
Version: 60 → unspecified
(Reporter)

Updated

5 months ago
Summary: Provider for Google Calendar: Can't change event date, always resets to 30.12.0002. → Can't change event date, always resets to 30.12.0002.

Comment 1

5 months ago
What timezone do you have configured? Is this also an issue if you create an event in a local calendar?
Flags: needinfo?(yusufaktepe)
Version: unspecified → Lightning 6.2
(Reporter)

Comment 2

5 months ago
(In reply to [:MakeMyDay] from comment #1)
> What timezone do you have configured? Is this also an issue if you create an
> event in a local calendar?

Time Zone: Europe/Istanbul

Yes, tried local calendar now, this issue is also present in there.

Version:
Thunderbird 60.0 (32bit)
Lightning 6.2
Provider for Google Calendar 4.4.1
Flags: needinfo?(yusufaktepe)

Comment 3

5 months ago
Sorry, I wasn't precise - can you disable the Provider addon, restart TB and check again with a local calendar, please?
(Reporter)

Comment 4

5 months ago
Unfortunately, the same result.

Comment 5

5 months ago
Ok, some more questions:

1. what is your platform?
2. do you see any eror messages in the error console when starting TB or reproducing the issue?
3. does the behaviour change if you switch to another timezone e.g. Europe/Berlin?
4. do you have any other addons installed and if so, does the issue persist if you disabled all of them and restarted TB?

Comment 6

5 months ago
One more thing:

5. if your are on Linux, where did you get TB / Lightning / Google Provider addon from?
(Reporter)

Comment 7

5 months ago
1. Windows 10 (1803) x64
2. When I click End Date and afterwards Start Date, I see an error says: "The end date you entered occurs before the start date" and resets to 30.12.0002. ( https://imgur.com/dL96d3Y )
   When I click Start Date first, I don't see any error and resets to 30.12.0002. ( https://imgur.com/4pghaWy )
   (These are happening when I haven't try to change the date yet, just clicking the area.)
3. Just tried it and still the same behaviour.
4. I have 4 addons. Active: Lightning (default), Provider for Google Calendar, ThunderKeepPlus. Disabled: Auto Select Latest Message.
   Disabled all except Lightning and tried with local calendar: still same behaviour.

Comment 8

5 months ago
Regarding #2 I was aksing for output from the error console (shift+ ctrl + j) - can you please check that?

Apart from that, can you reproduce the issue with a new profile, too?
(Reporter)

Comment 9

5 months ago
In console, I have:
While creating services from category 'profile-after-change', could not create service for entry 'calendar-backend-loader', contract ID 'service,@mozilla.org/calendar/backend-loader;1'
Use of Mutation Events is deprecated. Use MutationObserver instead.

Yes, also this is new profile.

Comment 10

5 months ago
Ok, that's not related. But I just noticed you're using an English UI - what locale of TB are you using? en-US? Do you use a localized Win10 version or also en English (which locale) one?
(Reporter)

Comment 11

5 months ago
I use English locale (default in thunderbird.net), should I try Turkish locale and check if issue still present?
(Reporter)

Comment 12

5 months ago
I also use Windows in English.

Comment 13

5 months ago
No, keep it for now. What have you set |Date and Time Formatting| in TB preferences > advanced -> general to? Does changing that setting and restarting TB change anything?
(Reporter)

Comment 14

5 months ago
It was "Regional settings locale: Turkish (Turkey)"
And I changed to "Application locale: English (United States)", restarted, tried to create event but the result is the same.
(Reporter)

Comment 15

5 months ago
If this is relevant, I kept open console while creating event and it prints this error:

RangeError: date value is not finite in DateTimeFormat.format()

Comment 16

5 months ago
That's probably expected since the date is a little out the usual range. Can also post the file and line this error occurs?

Then, can you please paste the following in to the box of the lower part of the error console:

getSelectedDay();

and press <enter>. This should print some data into the console. Can you please completely copy it an post it as well?
(Reporter)

Comment 17

5 months ago
File and line:
datetimepickers.xml:1875:20

Output:

getSelectedDay();
XPCWrappedNative_NoHelper { isMutable: true, isValid: true, nativeTime: 1533762000000000, year: 2018, month: 7, day: 9, hour: 0, minute: 0, second: 0, timezone: XPCWrappedNative_NoHelper }
Summary: Can't change event date, always resets to 30.12.0002. → Can't change event date, always resets to 30.12.0002. [RangeError: date value is not finite in DateTimeFormat.format()]

Comment 18

3 months ago
Confirming as per [1], though I still cannot reproduce this. Per comment 4, this is not a gdata issue.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1503731#c4
Status: UNCONFIRMED → NEW
Component: Provider: GData → Dialogs
Ever confirmed: true

Updated

3 months ago
Whiteboard: [datetime-issue-6.2]

Comment 19

2 months ago
Yusuf, over in bug 1503731, it turned out that changing the OS timezone from +03:00 Minsk to +03:00 Moscow makes the issue disappear. It's not yet clear what's happening, so can you provide some data points from your settings?

Please set please TB Options > Advanced > Date and Time Formatting to OS Regional Settings, then open the troubleshooting information (Menu > Help > Troubleshooting information) and post here what you get in the Internationalization & Localization section at the end once with your current OS timezone setting (which I assume is Istanbul). Then, please switch your OS timezone to Moscow, reboot and collect the same information from the troubleshooting page.
Flags: needinfo?(yusufaktepe)
(Reporter)

Comment 20

2 months ago
Both are identical.

Istanbul:

Internationalization & Localization
Application Settings
Requested Locales 	["en-US"]
Available Locales 	["en-US"]
App Locales 	["en-US"]
Regional Preferences 	["tr-TR"]
Default Locale 	"en-US"
Operating System
System Locales 	["en-US"]
Regional Preferences 	["tr-TR"]

Moscow:

Internationalization & Localization
Application Settings
Requested Locales 	["en-US"]
Available Locales 	["en-US"]
App Locales 	["en-US"]
Regional Preferences 	["tr-TR"]
Default Locale 	"en-US"
Operating System
System Locales 	["en-US"]
Regional Preferences 	["tr-TR"]
Flags: needinfo?(yusufaktepe)
(Reporter)

Comment 21

2 months ago
And yes, setting to Moscow fixes the issue.

Comment 22

2 months ago
Thanks, you see this on a 64 bit system, right?

To get further to the culprit, can you do two additoinal checks with changing the OS timezone and checking whether the issue occurs or disappears:

1. Nairobi
2. Baku (if this fails, do the values you see in case of the second issues look different then for Istanbul?)
(Reporter)

Comment 23

2 months ago
Yes, 64 bit.

No problem with either of them.

Comment 24

2 months ago
Thank you. Can you also do what I requested at [1]?

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1503731#c21
Flags: needinfo?(yusufaktepe)
(Reporter)

Comment 25

2 months ago
Tried with debug addon. I get these:

Lightning:Failed to format time value "Invalid Date" (object)  datetimepickers.xml:1878
Lightning:Invalid Date  datetimepickers.xml:1879
Flags: needinfo?(yusufaktepe)

Comment 26

2 months ago
Thanks - I have another debug version uploaded to 1503731 - can you check it with that again?
Flags: needinfo?(yusufaktepe)
(Reporter)

Comment 27

2 months ago
Lightning:Failed to format time value "Invalid Date" (object)  datetimepickers.xml:1938
Lightning:Invalid Date  datetimepickers.xml:1939
Flags: needinfo?(yusufaktepe)

Comment 28

2 months ago
We figured out the culprit in bug 1503731, which has a patch now.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1503731
You need to log in before you can comment on or make changes to this bug.