Implement a listener for WebVR PresentationGenerationContext changes

RESOLVED FIXED in Firefox 63

Status

()

enhancement
RESOLVED FIXED
10 months ago
10 months ago

People

(Reporter: imanol, Assigned: imanol)

Tracking

unspecified
mozilla63
All
Unspecified
Points:
---

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox-esr60 wontfix, firefox61 wontfix, firefox62 wontfix, firefox63 fixed)

Details

(Whiteboard: [geckoview:fxr:p1])

Attachments

(1 attachment)

Assignee

Description

10 months ago
On FirefoxReality we increate mPresentingGeneration value to exit from WebVR from a back button action. This normally works but I did some tests with webpages that don't call vrDisplay.SubmitFrame and Exit from WebVR didn´t work ok.

The problem is that mPresentingGeneration changes are only checked in VRDisplay::SubmitFrame(). We should add a listener dispatch by the watchdog also to protect from situations where vrDisplay.SubmitFrame() is not called.
Assignee

Updated

10 months ago
Whiteboard: [geckoview:fxr:p1]
Assignee

Comment 1

10 months ago
MozReview-Commit-ID: FAR1fYnNM0U
Since this patch touches dom/base/nsGlobalWindowInner.[h,cpp] you need a peer review. Maybe ehsan?
Assignee: nobody → imanol
Comment on attachment 8998127 [details]
Bug 1481393 - Implement a listener for WebVR PresentationGenerationContext changes;

Randall Barker [:rbarker] has approved the revision.

https://phabricator.services.mozilla.com/D2832
Attachment #8998127 - Flags: review+
Comment on attachment 8998127 [details]
Bug 1481393 - Implement a listener for WebVR PresentationGenerationContext changes;

:kip (Kearwood Gilbert) has approved the revision.

https://phabricator.services.mozilla.com/D2832
Attachment #8998127 - Flags: review+
I was told :nika is the correct peer to request the review from.
Comment on attachment 8998127 [details]
Bug 1481393 - Implement a listener for WebVR PresentationGenerationContext changes;

:Nika Layzell has approved the revision.
Attachment #8998127 - Flags: review+
Assignee

Updated

10 months ago
Keywords: checkin-needed

Comment 7

10 months ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/56bf1095268f
Implement a listener for WebVR PresentationGenerationContext changes; r=kip,rbarker,nika
Keywords: checkin-needed

Comment 8

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/56bf1095268f
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
status-firefox62=wontfix because we don't need to uplift this fix to GV 62 Beta.
You need to log in before you can comment on or make changes to this bug.