Closed Bug 1481406 Opened 4 years ago Closed 3 years ago

Can't draw a video element to canvas

Categories

(Firefox for Android Graveyard :: Audio/Video, defect)

Firefox 61
defect
Not set
normal

Tracking

(firefox64 affected, firefox65 affected)

RESOLVED DUPLICATE of bug 1486659
Tracking Status
firefox64 --- affected
firefox65 --- affected

People

(Reporter: gaikov, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.84 Safari/537.36

Steps to reproduce:

I'm trying to draw a video element into canvas:

video = document.createElement("video");
video.src = "testVideo.mp4";
video.autoplay = true;
video.loop = true;

context.drawImage(video, 0, 0, 400, 300);


I've tryed this: https://stackoverflow.com/questions/18580844/firefox-drawimagevideo-fails-with-ns-error-not-available-component-is-not-av

but it does not work the video is not visible only sound



Actual results:

Error console reports:
NS_ERROR_NOT_AVAILABLE: Component is not available


Expected results:

video should be rendered. in other browsers everything is fine
See Also: → 879717
Duplicate of this bug: 1505715
Thanks for the report!
I was able to reproduce on this pages as well:
- https://www.w3schools.com/tags/tryit.asp?filename=tryhtml5_canvas_drawimage_video
- https://codepen.io/kus/pen/aOqvWP/

Marking the bug as NEW. Tested with HTC 10(Android 8.0.0).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dupe of 1479947 which is a dupe of
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1486659

Note that https://bugzilla.mozilla.org/show_bug.cgi?id=1486659 is marked as fixed, but the bug, as reproduced in https://bugzilla.mozilla.org/show_bug.cgi?id=1481406#c2, is still present in Firefox for Android v68.2.1.

Yes, I confirm that. This bug has been around for a while now and is not fixed on latest Firefox for Android.

I can also replicate this on Firefox for Android v68.3.0 using the codepen link provided (https://codepen.io/kus/pen/aOqvWP/). The canvases are empty despite videos having loaded, and an error message "NS_ERROR_NOT_AVAILABLE: " is logged in the console.

Works fine on Chrome for Android v79.0.3945.79 (both videos and canvases are rendered).

Should I file a new report or should this one be reopened?

Neither. Firefox for Android 68 is a finished product. Checking the behavior on Firefox Review and/or reference browser would be the thing to do they are using Gecko 73. https://play.google.com/store/apps/details?id=org.mozilla.fenix.nightly & https://play.google.com/store/apps/details?id=org.mozilla.reference.browser

If it reproduces on those builds opening a bug at https://bugzilla.mozilla.org/enter_bug.cgi?product=GeckoView would be useful.

Thanks for tour hints. I just tried with Fenix nightly and I reproduce the bug :(

Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.