Closed Bug 1482113 Opened 3 years ago Closed 3 years ago

Don't collect metrics when previewing Snippets

Categories

(Firefox :: Messaging System, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 64
Iteration:
64.2 - Sep 28
Tracking Status
firefox63 --- wontfix
firefox64 --- verified

People

(Reporter: giorgos, Assigned: rrosario)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When previewing Snippets in AS Router we shouldn't collect any snippet related metrics (impression, click, etc).
Blocks: 1471328
Iteration: --- → 63.5 - Sep 3
Priority: -- → P3
Blocks: 1432588
No longer blocks: 1471328
Severity: normal → enhancement
Priority: P3 → P2
Priority: P2 → P3
Iteration: 63.5 - Sep 3 → 64.2 (Sep 28)
Priority: P3 → P2
To clarify, this is about previewing snippets using the about:newtab?endpoint=URL mechanism. *grabs*
Assignee: nobody → rrosario
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Blocks: 1493794
I've changed the 

browser.newtabpage.activity-stream.asrouter.messageProviders

pref to

[{"id":"onboarding","type":"local","localProvider":"OnboardingMessageProvider","enabled":false,"cohort":0},{"id":"snippets","type":"remote","url":"https://snippets.cdn.mozilla.net/%STARTPAGE_VERSION%/%NAME%/%VERSION%/%APPBUILDID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/","updateCycleInMs":14400000,"enabled":true},{"id":"cfr","type":"local","localProvider":"CFRMessageProvider","enabled":true,"cohort":"nightly"}]

which enabled snippets while I am on about:newtab#asrouter, but any action I take on the snippet is still considered valid. Which leads me to believe that I'm looking in the wrong place.

@Ricky, is there any other way I can verify this issue?
Flags: needinfo?(rrosario)
Sent the info on slack.

Testing doc:
https://docs.google.com/document/d/1rJXREddGUx0F7J3sseQbYXY_tkW4wL1CEyaxbRbn-pg/edit

in order to test this, you can follow the same steps in the document but instead whitelist `gist.githubusercontent.com` and use this endpoint https://gist.githubusercontent.com/piatra/70234f08696c0a0509d7ba5568cd830f/raw/41338334ba7e523020b0ea9a875f872ccb050633/messages.json
Flags: needinfo?(rrosario)
Thanks again Ricky for your help with this.

I have verified that the issue is no longer reproducible on the latest Nightly 64.0a1 (Build ID 20180927100044) on Windows 10 x64, Mac 10.13.3, and Arch Linux x64.
Status: RESOLVED → VERIFIED
The status for 63 was set to affected by the AS team - is this something we intend to request approval on or is it riding the trains?
Flags: needinfo?(rrosario)
QA Contact: tspurway
Oh I see. This isn't worth uplifting. Let it ride the choo choo
Flags: needinfo?(rrosario)
QA Contact: tspurway
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.