Closed Bug 1482397 Opened 2 years ago Closed 1 year ago

The user is not logged out when "Cookies" are disabled.

Categories

(GeckoView :: General, defect)

ARM
Android
defect
Not set

Tracking

(firefox61 affected, firefox62 affected, firefox63 unaffected, firefox64 unaffected, firefox65 unaffected)

RESOLVED WORKSFORME
Tracking Status
firefox61 --- affected
firefox62 --- affected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected

People

(Reporter: mirabela.lobontiu, Assigned: esawin)

References

(Blocks 1 open bug, )

Details

Device(s):
 - Sony Xperis Z5 Premium (Android 6.0.1);

Build(s):
 - Nightly 63.0a1 (2018-08-10);
 - Beta 62.0b15;
 - Release 61.0.2;

Steps to reproduce:
 1. Log in into Twitter on Firefox browser.
 2. Open Twitter in Custom tab.
 3. Go to Settings -> Privacy -> Cookies and select "Disabled".
 4. Open Twitter in Custom tab again.

Expected result:
 The user should not be logged in.

Actual result:
 The user is still logged in.
Sounds like this may be a geckoview issue.
Component: General → GeckoView
I couldn't reproduce the issue on Fennec 63, can you expand a bit on the steps, e.g., do you close the custom tab between step 2 and 3 and how do you open the custom tab?

If you happen to find the regression range, that would be ideal, but any more details to reproduce this would help.
Flags: needinfo?(mirabela.lobontiu)
Hi Eugen,

I could not reproduce either today.
Tested with:
 - Sony Xperia Z5 Premium (Android 6.0.1), 
 - Motorola Nexus 6 (Android 7.1.1) and
 - Samsung Galaxy S8 (Android 8.0).

I will close this issue as Works for me.
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(mirabela.lobontiu)
Resolution: --- → WORKSFORME
Assignee: nobody → esawin
Product: Firefox for Android → GeckoView
You need to log in before you can comment on or make changes to this bug.