Closed Bug 1482464 Opened Last year Closed Last year

Unpin stops working in Top Sites / TypeError: e.identifier is null

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- fixed
firefox63 --- fixed

People

(Reporter: nanj, Assigned: ahillier)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

An error, "TypeError: e.identifier is null.  TopSitesFeed.jsm:191:50", occurred when trying to unpin a top site in the latest nightly, this happened to other pinned sites as well with the same error message.
Blocks: 1479806
Priority: -- → P2
Assignee: nobody → ahillier
Noted on irc, e.identifier is `null` for added search engines. So probably just check null before using.
Duplicate of this bug: 1482495
Summary: Unpin stops working in Top Sites → Unpin stops working in Top Sites / TypeError: e.identifier is null
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Blocks: 1482523
Iteration: --- → 63.4 - Aug 20
https://hg.mozilla.org/mozilla-central/rev/322c3cf43fe8
Priority: P2 → P1
Target Milestone: --- → Firefox 63
Duplicate of this bug: 1482612
Blocks: 1482398
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.