Closed Bug 1482494 Opened Last year Closed Last year

Intermittent browser/base/content/test/urlbar/browser_urlbarSearchFunction.js | "" == "basic" - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/urlbar/browser_urlbarSearchFunction.js :: assertUrlbarValue :: line 210

Categories

(Firefox :: Address Bar, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox63 --- fixed
firefox64 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mak)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell disabled])

Attachments

(2 files)

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=193284159&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/EVm1nH9iRrWMKsW5_YsQ6g/runs/0/artifacts/public/logs/live_backing.log

07:24:14     INFO - TEST-START | browser/base/content/test/urlbar/browser_urlbarSearchFunction.js
07:24:15     INFO - TEST-INFO | started process screencapture
07:24:15     INFO - TEST-INFO | screencapture: exit 0
07:24:15     INFO - Buffered messages logged at 07:24:14
07:24:15     INFO - Entering test bound init
07:24:15     INFO - Leaving test bound init
07:24:15     INFO - Entering test bound basic
07:24:15     INFO - Buffered messages logged at 07:24:15
07:24:15     INFO - Restore popup dontAnimate value to false
07:24:15     INFO - Buffered messages finished
07:24:15     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/urlbar/browser_urlbarSearchFunction.js | "" == "basic" - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/urlbar/browser_urlbarSearchFunction.js :: assertUrlbarValue :: line 210
07:24:15     INFO - Stack trace:
07:24:15     INFO - chrome://mochitests/content/browser/browser/base/content/test/urlbar/browser_urlbarSearchFunction.js:assertUrlbarValue:210
07:24:15     INFO - chrome://mochitests/content/browser/browser/base/content/test/urlbar/browser_urlbarSearchFunction.js:basic:34
07:24:15     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
07:24:15     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1097
07:24:15     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:999
07:24:15     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
07:24:15     INFO - TEST-PASS | browser/base/content/test/urlbar/browser_urlbarSearchFunction.js | true == true -
This test was introduced with this changeset: https://hg.mozilla.org/integration/autoland/rev/9d267b4bd26889fe936dff2c7b05d3b9415ccb44 but did not start failing on that push http://tinyurl.com/ya5rl4zm

It was first classified over here http://tinyurl.com/y886mw8n and retriggering around that time https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=OS%20X%2010.10%20debug%20Mochitests%20with%20e10s%20test-macosx64%2Fdebug-mochitest-browser-chrome-e10s-3%20M-e10s(bc3)&fromchange=e57c44d5ec978b70bbfb0d44152b5625a5b8997a&tochange=c9cc4b80fefa156da51c83c6539453c1b84e71d9&selectedJob=193533285 showed up that it began failing with this push from Johann where it failed 6 times out of 20 - http://tinyurl.com/yavav5kx.

Johann, can you please take a look over this? Thank you.
Flags: needinfo?(jhofmann)
Whiteboard: [retriggered]
Well my patch touches a bit of stuff in the identity block, which is of course in close proximity to the urlbar, but I can't imagine that the root cause for the intermittentness lies in my patch. Drew, do you have any idea what this is? I'm generally happy to support the effort here but I have no idea what this test does or why code touching the identity block should affect it.
Flags: needinfo?(jhofmann) → needinfo?(adw)
There are 358 failures in the last 7 days.
Attached a patch to disable the test until the issue will be fixed
Attachment #9002156 - Flags: review?(jmaher)
Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered][stockwell disabled]
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a097b1bacf9
Disable browser_urlbarSearchFunction.js for frequent failures. r=jmaher
Keywords: checkin-needed
:Gijs, this is the other bug that made it hard to investigate and see failures in bug 1453723- again, this was recently disabled.
Flags: needinfo?(gijskruitbosch+bugs)
Sorry, haven't been able to make time here. However, I suspect the fix in bug 1485746 might fix this, too? Marco?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(mak77)
I'll look at this, so I'm clearing Marco's NI and leaving mine, I'm just a little chafed at being on the hook for fixing it when I didn't break it
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(mak77)
I wonder if the problem is similar to the other frequent failure we had, the test is not opening a new tab to run, but the harness is. When the harness opens a new tab it immediately starts running the test, but onLocationChange didn't fire yet, so you set the value to "basic", but immediately after it gets reset to the empty string.

I can push to Try and see if my theory is valid, by running the test in a new tab.
Assignee: adw → mak77
Comment on attachment 9006889 [details]
Bug 1482494 - Intermittent failure in browser_urlbarSearchFunction.js

Drew Willcoxon :adw has approved the revision.
Attachment #9006889 - Flags: review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/4cf474bee0be
Intermittent failure in browser_urlbarSearchFunction.js r=adw
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.