If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[4xp] From header wrong when reply-to address is used after migrate

RESOLVED WORKSFORME

Status

MailNews Core
Profile Migration
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Felix Miata, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
This is very old (many months), but I couldn't get Bugzilla to find anything
looking like this. Currently using OS/2 2002053008 trunk. FWIW, I did a fresh
migrate from 4xp without impacting this. The migration included one email
account and six news server accounts.

To reproduce:
1-Complete in prefs news account identity the fields:
     Your Name:
     Email Address:
     Reply-to Address:
using non-matching email addresses
2-Compose and send news

Actual results headers in form as follows:
     emailaddress <emailaddress>
     reply-toaddress

Expected results headers in form as follows:
     yourname <emailaddress>
     reply-toaddress
(Reporter)

Comment 1

16 years ago
Created attachment 85684 [details]
Screenshot of news account settings
(Reporter)

Comment 2

16 years ago
Created attachment 85685 [details]
Screenshot of result of using pref settings in attachment  85684 [details]

Comment 3

16 years ago
Does it happen with a non migrated profile?
(Reporter)

Comment 4

16 years ago
With a fresh from scratch profile it worked as expected (Fri, 31 May 2002
11:21:25 -0400 to netscape.public.mozilla.os2 with subject "Mailnews Bug 148267
Test"), but I did not create any of the other news server accounts, only one
necessary to test post. Should I have created multiple news servers before
testing? Need I try creating others now?
Keywords: 4xp
(Reporter)

Comment 5

16 years ago
If you look at the thread referred to in comment 4 on
news:netscape.public.mozilla.os2 you will see I tried many things to cause the
same behavior after creating a new profile from scratch. No success, so it looks
like this must be some kind of migration problem. Changing component to profile
migration from account manager.
Component: Account Manager → Profile Migration

Comment 6

16 years ago
Can you post a screenshot of your 4.x settings so I can migrate them?
(Reporter)

Comment 7

16 years ago
It would take a lot of screenshots to get both the email and the six news
servers. Want to try using my prefs first? (emailed already)
(Reporter)

Comment 8

16 years ago
This did not happen again when I migrated fresh with 2002060216 (preliminary
v1.0 release for OS/2). I'll try another migrate on the trunk probably wednesday
or thursday.
(Reporter)

Comment 9

16 years ago
I migrated the 2002060608 trunk today and experienced the problem exactly as
originally reported.
(Reporter)

Comment 10

16 years ago
Something I didn't notice before now is a disparity between the "from" displayed
in the XUL message header and the message's actual from header. Here is the
"from" from the last email I sent, copied & pasted from Netscape:

     From: "UgaddaBkidding.due2UCE" <"UgaddaBkidding.due2UCE"@atlantic.net>

Note the extra pair of quotes missing from the XUL display in attachment 85685 [details].
This probably is or should be another bug (search came up empty), but may be
related to the problem here and unnecessary at this point. Bugs I read: 134277,
117975, 39955.

"after migrate" and "trunk" added to summary.
Summary: [4xp] From header wrong when reply-to address is used → [trunk][4xp] From header wrong when reply-to address is used after migrate

Comment 11

16 years ago
I can't reproduce this problem on the 6/21 build. Do you still see 
this problem on current builds.
(Reporter)

Comment 12

16 years ago
Still broken in 2002062408 trunk.

Note this bug is still marked "unconfirmed". No one but me seems to be able to
reproduce this.

Note also in the screenshot both the long length of the from address and the
second period in the from address. Maybe these are why no one can reproduce this.
(Reporter)

Comment 13

15 years ago
Still broken in OS/2 1.1b release build 2002072910. [trunk] removed from summary.
Summary: [trunk][4xp] From header wrong when reply-to address is used after migrate → [4xp] From header wrong when reply-to address is used after migrate
(Reporter)

Comment 14

15 years ago
No improvement in today's official 1.1 release build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 15

15 years ago
WFM now in OS/2 2002101717 1.2b release build. Minor differences in profile
freshly migrated:

1-Old email address: Felix Miata <UgaddaBkidding.due2UCE@atlantic.net>
  New email address: Felix Miata <UgaddaBkidding.due2UCE@dev.nul>

2-Old reply-to address: mrmazda@atlantic.net
  New reply-to address: find@web.site

I did not test to see if the five character shorter email address was the
difference.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.