Closed Bug 1482681 Opened Last year Closed Last year

Right click "This Frame" > "Open Frame in New Tab" stops working

Categories

(Core :: DOM: Security, defect)

63 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed

People

(Reporter: alice0775, Assigned: jkt)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Reproducible : always:

Steps To Reproduce:
1. Open a page with iframe
   e.g, https://www.scollabo.com/banban/ref/sample/sample_61.html

2. Right click on a iframe
3. Choose "This Frame" > "Open Frame in New Tab" stops working

Actual Results:
Nothing happens.
The following error is shown in Browser Console:
Error: Required argument triggeringPrincipal missing within loadOneTab tabbrowser.js:1378:13

Expected Results:
Frame contents should open in new tab

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e17409c5199c0ade0de9899782d6a9f5f4970871&tochange=6f3907a1da34a62133832dc981e9005ee30e9388

Regressed by: Bug 1362034
Just writing up a test for this, I have a fix already.
Assignee: nobody → jkt
(In reply to Jonathan Kingston [:jkt] from comment #2)
> Created attachment 8999555 [details]
> Bug 1482681 - Fix load iframe in tab context menu.

You should add your support file under the specific test rather than [DEFAULT].
Comment on attachment 8999555 [details]
Bug 1482681 - Fix load iframe in tab context menu.

Johann Hofmann [:johannh] has approved the revision.
Attachment #8999555 - Flags: review+
Pushed by jkingston@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e8a70b46acab
Fix load iframe in tab context menu. r=johannh
https://hg.mozilla.org/mozilla-central/rev/e8a70b46acab
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Is there a followup for correcting the triggering principal here (ie use that of the enclosing document, not necessarily that of the toplevel doc) ?
Flags: needinfo?(jkt)
Depends on: 1484735
You need to log in before you can comment on or make changes to this bug.