Closed Bug 1482731 Opened Last year Closed Last year

The keyboard "home/origin" and "end" keys no longer work in the tabs list

Categories

(Firefox :: Tabbed Browser, defect, P2)

63 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- wontfix
firefox63 --- verified

People

(Reporter: yaurthek, Assigned: mstriemer)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180805231147

Steps to reproduce:

The vertical tabs list that appears when there are too many tabs no longer responds to the origin and end keyboard keys since a recent Nightly update (a few weeks at most).

With Nightly:
- open lots of tabs (to display the tabs list button, and to make the vertical tabs list too big for the screen, so that it can scroll).
- click the button so that the vertical tabs list is showing.
- ensure the list is too big for the screen and has become scrollable.
- try to press the origin/end/page down/page up etc keyboard keys.


I just noticed that if I manage to put the focus on the list (doable using the up and down keys), it scrolls when pressing the above mentioned keys.


Actual results:

With a recent version of Nightly, nothing happens anymore. The vertical tabs list can no longer be scrolled with the keyboard.


Expected results:

I expect the vertical tabs list to respond to the origin/end/page down/page up etc keyboard keys, as it was the case before.
Blocks: 1446101
Has STR: --- → yes
Component: Untriaged → Tabbed Browser
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Ever confirmed: true
Keywords: regression
Mark, can you take a look?
Flags: needinfo?(mstriemer)
Priority: -- → P2
Assignee: nobody → mstriemer
Flags: needinfo?(mstriemer)
Attachment #9003488 - Flags: review?(dao+bmo)
Comment on attachment 9003488 [details]
Bug 1482731 - Support Home and End in PanelMultiView navigation r?dao

Dão Gottwald [::dao] has approved the revision.
Attachment #9003488 - Flags: review+
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8d1999b7f997
Support Home and End in PanelMultiView navigation r=dao
https://hg.mozilla.org/mozilla-central/rev/8d1999b7f997
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Hi,

I'm sorry but the bug is only partially fixed.

The end key works as before (goes to the last tab in the list), but the home key just selects the top button in the panel, which for me is the "Undo Close Tab" button.

I would expect the home button to go to the firs tab in the list instead, as it was the case before.

Also, I don't know whether this is intended as I didn't use them much before, but the page-up and page-down keys don't work unless you first focus an item in the list.

Maybe instead of dealing with some keys as special cases (I believe this is what the current fix does?), it would be easier and better to focus the list when it shows? (I expect the list control to already handle all the navigation keys properly, but maybe I'm wrong...)

Thank you for your time.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to yaurthek from comment #6)
> I would expect the home button to go to the firs tab in the list instead, as
> it was the case before.

That's not true.

Anyway, please file new bugs for any followup issues.
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
> That's not true.

You are right, sorry.

I thought I remembered that, but that's not exactly what was happening.

Pressing home indeed selected the first item in the menu (not the first tab), but since there was no scrollbar, this action would also show the first tabs.

Now it selects the first item as before, but because there is an independent scrollbar for the tabs, the tabs in the list are not affected by this action and stay in their current position (if the first tabs where hidden, they stay hidden).

This is inconvenient for me, but I'm not sure it's worth opening another bug/feature request.

(For the record, I also checked the behavior of the page-up and page-down buttons, and it appears I was mistaken there too: they didn't do anything before the addition of the scrollbar)

Anyway, sorry, and thanks again for your time.
Attached image Bug1482731.gif
I was able to reproduce this issue on Firefox 63.0a1(20180829100131) under Win 7 64-bit and  Mac OS X 10.13.3.

This issue is verified as fixed on Firefox 63.0a1(20180904100126) under Win 7 64-bit and Mac OS X 10.13.3.

Windows: Home/End buttons.
Mac OS X: fn+Left/Right arrows.

Please see the attached video.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.