Closed Bug 1482865 Opened Last year Closed Last year

@searches Top Sites from the "Add Search Engines" menu overlap when the browser is horizontally resized

Categories

(Firefox :: New Tab Page, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- verified
firefox63 --- verified

People

(Reporter: cmuresan, Assigned: rrosario)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

[Affected versions]:
- Nightly v63.0a1, Build ID 20180812220618

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Open the browser with a clean new profile.
2. Click the "..." Top Sites section button and click the "Add Search Engine" option.
3. Resize the browser to a quarter screen.
4. Observe the behavior.

[Expected results]:
- The @searches Top Sites are displayed in a grid.

[Actual results]:
- One of the @searches Top Site overlaps the one before it.

[Notes]:
- Attached a screen recording of the issue.
Iteration: --- → 63.4 - Aug 20
Priority: -- → P3
Assignee: nobody → rrosario
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/5fe21cda2ba9ad87cc7530211e3f41833768bff0
Fix Bug 1482865 - fix searchy overlap when resizing window

https://github.com/mozilla/activity-stream/commit/f97fcb054e587da732b1b6daea1daf217865a36b
Merge pull request #4327 from rlr/bug1482865/overlap-fix

Fix Bug 1482865 - fix searchy overlap when resizing window
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Blocks: 1482959
Blocks: 1482398
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180816100035) on Windows 10, Mac 10.13 and Arch Linux x64.
Status: RESOLVED → VERIFIED
Fix confirmed for 62.0b18 on Windows 10x64, Ubuntu 18.04LTS, macOS10.13.
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.