Closed Bug 1482898 Opened 2 years ago Closed 2 years ago

Make root requirement in mozdevice optional

Categories

(Testing :: Mozbase, enhancement)

Version 3
enhancement
Not set

Tracking

(firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: wlach, Assigned: wlach)

References

Details

Attachments

(1 file, 1 obsolete file)

To support mozregression, which is mostly used with unrooted devices, we should make it possible to initialize ADB without root permissions (this was broken in bug 1440714).
Comment on attachment 8999626 [details] [diff] [review]
Patch to make root requirement optional

Review of attachment 8999626 [details] [diff] [review]:
-----------------------------------------------------------------

Looks ok to me. This is sufficient to allow mozregression to work? r+
Attachment #8999626 - Flags: review?(bob) → review+
(In reply to Bob Clary [:bc:] from comment #2)
> Comment on attachment 8999626 [details] [diff] [review]

> Looks ok to me. This is sufficient to allow mozregression to work? r+

I believe so, haven't tested mozregression itself but am 99% sure.

Here's a try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9fe4935382c28742440da69ef00be0cfc85a0f81
Adding a version bump to mozdevice, carrying forward r+
Attachment #8999626 - Attachment is obsolete: true
Attachment #8999718 - Flags: review+
Try run looks good, can someone land this for me?
Keywords: checkin-needed
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6f69e8083284
Support running adb commands in mozdevice as non-root;r=bc
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6f69e8083284
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Blocks: 1478502
Duplicate of this bug: 1478502
No longer blocks: 1478502
The above patch actually didn't quite fix things :( Sorry for the churn
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Actually, I forgot that we should file followups if additional changes are asked for, I'll do that: bug 1483221
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.