Closed Bug 1483135 Opened Last year Closed Last year

The @google, @amazon ... tiles are not tabable with the keyboard, only their context menu buttons are.

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: MarcoZ, Assigned: ursula)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is because these are html:a elements with an onclick handler, but no href attribute. Accessibility sees them as links fine, but DOM doesn't consider them focusable because of the missing href.

Easy fix: Slap an tabindex="0" attribute onto them.

Priority suggestion: This should be done for current release as to give keyboard-only users a full accessible experience for these.
tabindex=0 is insufficient to trigger the onclick here, but it does allow it to be tabbed to.
OS: Windows 10 → All
Hardware: x86 → All
Iteration: --- → 63.4 - Aug 20
Assignee: nobody → usarracini
Priority: P2 → P1
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/c9ab6cf948316f0d9a62349d21721765fec940db
Fix Bug 1483135 - Search shortcuts are not tabbable

https://github.com/mozilla/activity-stream/commit/b4046f78aafb66af96f183353696a7c37af6529e
Merge pull request #4337 from sarracini/bug_1483135

Fix Bug 1483135 - Search shortcuts are not tabbable
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Blocks: 1483375
Blocks: 1482398
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180816100035) on Windows 10, Mac 10.13 and Arch Linux x64.
Status: RESOLVED → VERIFIED
I managed to reproduce the issue using an older version of Firefox (2018-08-14) on Windows 10.
I retested everything using beta 62.0b18 on Windows 10 x64, Ubuntu 16.04 x64 and macOS 10.13. The bug is not reproducing anymore.
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.