Closed Bug 1483293 Opened 2 years ago Closed 2 years ago

blob invalidation: Google Slides 'Fade in' transition doesn't work

Categories

(Core :: Graphics: WebRender, defect, P1)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- disabled
firefox62 --- disabled
firefox63 --- disabled
firefox64 --- fixed

People

(Reporter: dheiberg, Assigned: jrmuizel)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Nightly: 63.0a1 (2018-08-13) (64-bit)
OS: Mac OS High Sierra 10.13.6
gfx.webrender.all set to true

When presenting something in Google Slides with 'fade in' animations on click, they don't actually render, but the presentation is still going and clicking again will move to the next slide. When turning WebRender off, the animations work as expected. I have linked an example presentation where this bug occurs:
https://docs.google.com/presentation/d/1YLOEB66RYShbxvvbGajPxnCee70NcnpyWfiqzcpl9c4/edit?usp=sharing
I was looking at https://docs.google.com/presentation/d/1n2RlMdmv1p25Xy5thJUhkKGvjtV-dkAIsUXP-AL4ffI/preview today and noticed similar problems (current Nightly on macOS).
Start the presentation. Click on the slide: An image should fade in.
mozregression --good 2018-04-01 --bad 2018-08-13 --pref gfx.webrender.all:true -a https://docs.google.com/presentation/d/1YLOEB66RYShbxvvbGajPxnCee70NcnpyWfiqzcpl9c4/edit
> 4:06.75 INFO: Last good revision: 38cfaf35c4c1b2761c97c78769496b3181a6eedc
> 4:06.75 INFO: First bad revision: 2a2282923b5abdf8b95bad5a59e694ac8e744883
> 4:06.75 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=38cfaf35c4c1b2761c97c78769496b3181a6eedc&tochange=2a2282923b5abdf8b95bad5a59e694ac8e744883

> 2a2282923b5a	Jeff Muizelaar — Bug 1450015. Enable blob invalidation by default. r=gankro
Flags: needinfo?(jmuizelaar)
Keywords: regression
OS: Unspecified → All
Version: 63 Branch → Trunk
Ok, fun. It'd be nice to have a reduced test case of this.
Summary: Google Slides 'Fade in' transition doesn't work → blob invalidation: Google Slides 'Fade in' transition doesn't work
Priority: -- → P2
It seems as though the opacity animation is not happening properly.
Flags: needinfo?(jmuizelaar)
After some exploration this looks like this has the same root cause as Bug 1487903, so fixing that *should* fix this. Jeff is on it.
Depends on: 1487903
Assignee: nobody → jmuizelaar
Priority: P2 → P1
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.