Status

()

enhancement
P5
normal
RESOLVED DUPLICATE of bug 1429421
8 months ago
8 months ago

People

(Reporter: jesus.christus, Assigned: soeren.hentzschel, Mentored)

Tracking

60 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20100101

Steps to reproduce:

these 3 are dead since FF62 (https://bugzilla.mozilla.org/1462398):
- devtools.gcli.jquerySrc
- devtools.gcli.lodashSrc
- devtools.gcli.underscoreSrc

fe. https://dxr.mozilla.org/mozilla-central/search?q=underscoreSrc

and 'dom.ipc.shims.enabledWarnings' is dead since FF60 (https://hg.mozilla.org/mozilla-central/rev/beaba4c0ac0c). see https://dxr.mozilla.org/mozilla-central/search?q=enabledWarnings

Comment 1

8 months ago
AIUI, from the about:config or any other Firefox interface, it is not possible today to clean up preferences, but having more or less preferences does not impact performance or functionality.

From what I know there are no known procedures in how to handle "dead" preferences. I also don't know if the listed preferences are really dead, so I will mark the issue as an enhancement and set component Preferences.
Severity: normal → enhancement
Component: Untriaged → Preferences
Mentor: mconley
Priority: -- → P5
Assignee: nobody → cadeyrn
Comment on attachment 9005854 [details]
Bug 1483352 - remove dead gcli preferences from devtools-shared.js

Mike Conley (:mconley) (:⚙️) has approved the revision.
Attachment #9005854 - Flags: review+
(Assignee)

Updated

8 months ago
Keywords: checkin-needed
Sören, there were conflicts applying your patch. Please fix and attach the new version.

Error: We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again. (255, 'applying /tmp/tmpHWZvr7\npatching file devtools/shared/preferences/devtools-shared.js\nHunk #1 FAILED at 70\n1 out of 1 hunks FAILED -- saving rejects to file devtools/shared/preferences/devtools-shared.js.rej\nabort: patch failed to apply', '')
Flags: needinfo?(cadeyrn)
Keywords: checkin-needed
(Assignee)

Comment 5

8 months ago
Oops. I wanted to rebase the patch and did a `hg pull`. Then I saw there is a `hg pull --rebase`and found in the documentation:

> If you had done a normal hg pull without --rebase after your hg commit, you will have to first undo that by doing hg rollback.

But I can't execute `hg rollback` because of:

> abort: rollback is disabled because it is unsafe

What is the best way forward?
Flags: needinfo?(cadeyrn)
Hi Soren,

This is what I'd do:

1) Find the SHA of the commit you want to rebase. I assume this is still where your current working directory is at, so I'd do | hg log | or | hg summary | to get that.

Let's pretend that SHA is abcd1234

2) Once you have that, I think you can tell Mercurial to rebase that onto "tip" (which should be the most recent commit from central that you'd pulled down).

| hg rebase -r abcd1234 --dest tip |

And that should do it. Then you can | hg update | to tip, and push to Phabricator from there.


Does that work?
Flags: needinfo?(cadeyrn)
(Assignee)

Comment 7

8 months ago
Yes, that worked! But I noticed the preferences from comment #0 have been removed by the patch in bug 1429421, so there is nothing more to do here. I will mark this bug as duplicate of bug 1429421. At least now I know how to rebase in Mercurial. I am sure I will need this sometime in the future. Thank you, Mike! :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(cadeyrn)
Resolution: --- → DUPLICATE
Duplicate of bug: gcli-removal
You need to log in before you can comment on or make changes to this bug.