Closed Bug 1483408 Opened Last year Closed Last year

Player is not focused even with bug 1474574

Categories

(Toolkit :: XUL Widgets, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla63
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: timdream, Assigned: timdream)

References

Details

Attachments

(1 file)

Spin the failed QA verify to another bug.

This is a bit tricky to reproduce, hopefully I can verify the failure in a test:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=5e9bf51499c8fb7c0d8bd1016ac985584db6a9b3
Priority: -- → P2
For some reason we might miss the initial focus event. This ensures the video
element is focused when the document loads.
Comment on attachment 9001395 [details]
Bug 1483408 - Set focus to the video element when the media document loads r=Gijs

:Gijs (he/him) has approved the revision.
Attachment #9001395 - Flags: review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/59c5a173a09d
Set focus to the video element when the media document loads r=Gijs
https://hg.mozilla.org/mozilla-central/rev/59c5a173a09d
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Comment on attachment 9001395 [details]
Bug 1483408 - Set focus to the video element when the media document loads r=Gijs

Approval Request Comment (copied and modified from bug 1474574)
[Feature/Bug causing the regression]: regression of bug 1444489
[User impact if declined]: The user will not always be able to use keyboard to control media documents.
[Is this code covered by automated tests?]: This patch adds some test coverage.
[Has the fix been verified in Nightly?]: Not yet.
[Needs manual test from QE? If yes, steps to reproduce]: See comment 0, bug 1474574 comment 17 and later.
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: minor behavior fix, unlikely to break other things.
[String changes made/needed]: no.
Attachment #9001395 - Flags: approval-mozilla-beta?
Verified, that the issue is no longer reproducible on Nightly 63.0a1(20180820222055), the media player is focused after opening media files.
Status: RESOLVED → VERIFIED
Comment on attachment 9001395 [details]
Bug 1483408 - Set focus to the video element when the media document loads r=Gijs

Follow-up fix to bug 1474574. Verified by QA on Nightly. Approved for 62.0b20.
Attachment #9001395 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
I reproduced the initial issue on Firefox 61.0.2.
Verified fixed on Windows 10 x64, Ubuntu 16.04 x64 and macOS 10.12.6 using the 62.0b20 taskcluster build from 2018-08-23.
Flags: qe-verify+
Depends on: 1484544
You need to log in before you can comment on or make changes to this bug.