Closed Bug 1483651 Opened Last year Closed 11 months ago

`mach vendor python` should dereference symlinks from vendored packages

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: ted, Assigned: ted)

References

Details

Attachments

(1 file)

In bug 1461992 I used `mach vendor python` to update the version of our vendored copy of `voluptuous`, which wound up updating the vendored copy of `funcsigs` as well. This worked, but I couldn't push the patch because the `funcsigs` package included a symlink, which our hg server rejects:
remote: ****************************** ERROR *******************************
remote: 6cc7ca34fe90 adds or modifies the following symlinks:
remote: 
remote:   third_party/python/funcsigs/docs/index.rst
remote: 
remote: Symlinks aren't allowed in this repo. Convert these paths to regular
remote: files and try your push again.
remote: ********************************************************************

We should make sure that `mach vendor python` avoids this, even if it's uncommon.
Assignee: nobody → ted
At least one Python package that got vendored via `mach vendor python`
contains a symlink, which hg.mozilla.org rejects. This change makes it so
symlinks get replaced with the contents of the file they point to.
Comment on attachment 9003557 [details]
bug 1483651 - Dereference symlinks inside vendored Python packages. r=gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9003557 - Flags: review+
Duplicate of this bug: 1495027
This had to be backed out due to merge conflicts with bug 1490253. Feel free to rebase and re-land whenever.
Flags: needinfo?(ted)
Attachment #9003557 - Attachment description: bug 1483651 - Dereference symlinks inside vendored Python packages. r?gps → bug 1483651 - Dereference symlinks inside vendored Python packages. r=gps
Flags: needinfo?(ted)
Pushed by tmielczarek@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f5c1a7734493
Dereference symlinks inside vendored Python packages. r=gps
https://hg.mozilla.org/mozilla-central/rev/f5c1a7734493
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.