Replace remaining uses of webconsole.svg sprite

RESOLVED FIXED in Firefox 63

Status

RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: fvsch, Assigned: fvsch)

Tracking

unspecified
Firefox 63

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

7 months ago
Depends on: bug 1479750.
Can be assigned to me.

After my proposed changes to Console icons land in bug 1479750, the webconsole.svg sprite can be removed as long as we update other tools that happen to use it:

- debugger.css (1 use)
- jit-optimisations.css (1 use)
- memory.css (1 use)
- performance.css (1 use)

I suspect most are using the "error", "warning" or "info" icons.
(Assignee)

Updated

7 months ago
Depends on: 1479750
(Assignee)

Comment 4

7 months ago
Updated the icons to *not* use a white character fill.

One instance of the alert icon is in the Performance tool, in a menu. Since the orange icon with a transparent character looked a bit strange with some backgrounds, I opted to use the text color as the icon color, which seems more consistent with how Firefox and the DevTools treat icons in menus (both system menus and Photon menus). 

Try again with those changes:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f89f1b76f36aa358b7c403afb3203daf9f6e3b77

Comment 5

7 months ago
Comment on attachment 9003998 [details]
Bug 1483782 - Remove old webconsole.svg sprite; r=nchevobbe

Nicolas Chevobbe [:nchevobbe] has approved the revision.
Attachment #9003998 - Flags: review+

Comment 6

7 months ago
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/be371572ef39
Remove old webconsole.svg sprite; r=nchevobbe

Comment 7

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/be371572ef39
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
status-firefox63: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Assignee: nobody → florens
You need to log in before you can comment on or make changes to this bug.