Closed Bug 1483924 Opened 3 years ago Closed 3 years ago

Add 'OISTE WISeKey Global Root GC CA' root certificate to NSS

Categories

(NSS :: CA Certificates Code, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kwilson, Unassigned)

References

Details

(Whiteboard: In NSS 3.39, Firefox 63)

Attachments

(1 file)

This bug requests inclusion in the NSS root store of the following root certificate owned by WISeKey.

Friendly Name: OISTE WISeKey Global Root GC CA
Cert Location: https://bugzilla.mozilla.org/attachment.cgi?id=8912737
SHA-1 Fingerprint: E011845E34DEBE8881B99CF61626D1961FC3B931
SHA-256 Fingerprint: 8560F91C3624DABA9570B5FEA0DBE36FF11A8323BE9486854FB3F34A5571198D
Trust Flags: Email; Websites
Test URL: https://gcvalidssl.hightrusted.com/

This CA has been assessed in accordance with the Mozilla project guidelines, and the certificate approved for inclusion in bug #1403591

The next steps are as follows:
1) A representative of the CA must confirm that all the data in this bug is correct, and that the correct certificate has been attached.
2) A Mozilla representative creates a patch with the new certificate, and provides a special test version of Firefox.
3) A representative of the CA uses the test version of Firefox to confirm (by adding a comment in this bug) that the certificate has been correctly imported and that websites work correctly.
4) The Mozilla representative requests that another Mozilla representative review the patch.
5) The Mozilla representative adds (commits) the patch to NSS, then closes this bug as RESOLVED FIXED.
6) At some time after that, various Mozilla products will move to using a version of NSS which contains the certificates. This process is mostly under the control of the release drivers for those products.
Pedro, Please see step #1 above.
Summary: Add OISTE WISeKey Global Root GC CA'root certificate to NSS → Add 'OISTE WISeKey Global Root GC CA' root certificate to NSS
Dear Kathleen,
as representative of WISeKey SA, I can confirm that the data in this bug is correct. I verified the CA Certificate and it's attributes, matching the requested inclusion.
Thanks and best regards,
Pedro
Thanks, Pedro.

Root inclusions are usually grouped and done as a batch when there is either a large enough set of changes or about every 3 months. It just happens that we have enough time to add this change to the current batch of root changes that is planned for the upcoming NSS 3.39 release.

A test build will be provided and this bug will be updated to request that you test it. Since you are cc'd on this bug, you will get notification via email when that happens.
Thanks, Kathleen. 
I'll stay tuned and I'll be glad to do the required testing.
Best,
Pedro
Depends on: 1478638
Pedro,

The test build is available here:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=880794fdd7619a50e861b158e8e359672df5291a

Please test as described here:
https://wiki.mozilla.org/CA/Application_Instructions#Test

Then add a comment in this bug as soon as you have completed your testing.
Dear Kathleen,
I just did the testing. In particular:
- I installed the nightly build in a Mac
- I refreshed the settings using the "Refresh Firefox button"
- I checked that the requested CA appears as a new built-in object, and that the details match the inclusion request
- I navigated to the test site https://gcvalidssl.hightrusted.com and checked that there's implicit trust on its SSL certificate

Therefore, I'd say that everything is perfect.

Thanks again for processing our inclusion request and best regards,
Pedro
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Whiteboard: In NSS 3.39, Firefox 63
You need to log in before you can comment on or make changes to this bug.