Closed Bug 1483990 Opened 2 years ago Closed 2 years ago

72.22 - 93.03% build times (android-4-0-armv7-api16, android-4-2-x86) regression on push 19f9ed0f53b917f064655375341db76a9c5a4461 (Tue Aug 14 2018)

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: regression)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=19f9ed0f53b917f064655375341db76a9c5a4461

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 93%  build times android-4-0-armv7-api16 opt taskcluster-m4.2xlarge     1,013.79 -> 1,956.89
 72%  build times android-4-2-x86 opt taskcluster-m5.4xlarge             530.96 -> 914.43


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=14989

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Product: Testing → Firefox Build System
this is hard to tell if the real culprit is bug 1480006, or not- it is the most likely suspect and in common in most of the ranges.  Since we build on so many different types of machines, the signal we get is broken up.

:glandium, does it seem reasonable that your change from bug 1480006 would cause a large regression in build time for android?
Flags: needinfo?(mh+mozilla)
Yes, it's expected. LTO means more optimization, and that takes time. We should have seen talos perf improvements as well.
Flags: needinfo?(mh+mozilla)
we don't have any android perf tests at the moment, possibly next week a few will get turned on.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1489105
Depends on: 1530057
You need to log in before you can comment on or make changes to this bug.