[ps] CSS sans-serif prints as serif

RESOLVED FIXED

Status

()

Core
Printing: Output
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Steve White, Assigned: Pete Zha)

Tracking

({relnote})

Trunk
x86
Linux
relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020531
BuildID:    2002053108

This is Linux Mandrake 8.0 using CUPS system.

If text is styled as "font-family: sans-serif", it will be displayed
correctly in a sans-serif font, but it prints as a serif font.

However, if the font-family is set to monospace, the text is printed
in a monospace font, and if the font-family is set to some explicit
family, such as helvetica, it also prints correctly.

In previous versions (NS 6.2 and before), all CSS-styled text would print in a
serif font.


Reproducible: Always
Steps to Reproduce:
1.go to page with text with attribute style="font-family: sans-serif"
2.print page.
3.

Actual Results:  The text is printed as serif font (although other formatting, 
such as size and weight, are correctly printed)

Expected Results:  Should have printed in sans-serif face, shouldn't it?
Linux build 2002052421 here:

print preview -> sans-serif (as written on the textpage)
printing -> serif (and so there's the bug)
no dup found, so confirm..
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Created attachment 85813 [details]
Testcase (same as http://www.goldang.org/~white/docs/computers/browsers/fontprinting.htm)

Updated

16 years ago

Comment 4

16 years ago
Created attachment 85816 [details]
Testcase printed with Xprint module (300 DPI, DIN-A4)

Reporter:
Does this PS file print OK for you ?
(Reporter)

Comment 5

16 years ago
Yes, Roland, that is what it was supposed to look like.
(The difference would have been in the line "sans-serif 12pt")

It would appear that this shows that the problem isn't in the
Xprint module, but in the PostScript module (I think CUPS uses
Ghostscript to convert PostScript into a printer file.)

Updated

16 years ago
Summary: CSS sans-serif prints as serif → [ps] CSS sans-serif prints as serif

Comment 6

16 years ago
Added item to the release notes
(http://bugzilla.mozilla.org/show_bug.cgi?id=133795#c77) ...
Keywords: relnote

Comment 7

16 years ago
looks like PS issue over to don
Assignee: rods → dcone
(Assignee)

Updated

16 years ago
Blocks: 157675
(Assignee)

Comment 8

16 years ago
Created attachment 91622 [details] [diff] [review]
patch

fix the font name "sans serif" to "sans-serif"
need r=&sr=
(Assignee)

Comment 9

16 years ago
taking
Assignee: dcone → pete.zha

Comment 10

16 years ago
Comment on attachment 91622 [details] [diff] [review]
patch

r=dcone
Attachment #91622 - Flags: review+
Comment on attachment 91622 [details] [diff] [review]
patch

sr=bzbarsky
Attachment #91622 - Flags: superreview+

Comment 12

16 years ago
Comment on attachment 91622 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to 1.1
Attachment #91622 - Flags: approval+
(Assignee)

Comment 13

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.