Perma xpcshell in browser/extensions/formautofill/test/unit/heuristics/*.js when Gecko 63 merges to Beta on 2018-08-27

VERIFIED FIXED in Firefox 63

Status

()

defect
P1
normal
VERIFIED FIXED
9 months ago
8 months ago

People

(Reporter: ebalazs_, Assigned: kmag)

Tracking

unspecified
mozilla63
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63+ verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Comment 1

9 months ago
INFO -  TEST-START | browser/extensions/formautofill/test/unit/heuristics/test_basic.js
[task 2018-08-17T13:44:19.482Z] 13:44:19  WARNING -  TEST-UNEXPECTED-FAIL | browser/extensions/formautofill/test/unit/heuristics/test_basic.js | xpcshell return code: 0
[task 2018-08-17T13:44:19.483Z] 13:44:19     INFO -  TEST-INFO took 3612ms
[task 2018-08-17T13:44:19.485Z] 13:44:19     INFO -  >>>>>>>
[task 2018-08-17T13:44:19.486Z] 13:44:19     INFO -  PID 9262 | [9262, Main Thread] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2718
[task 2018-08-17T13:44:19.486Z] 13:44:19     INFO -  PID 9262 | JavaScript strict warning: /builds/worker/workspace/build/tests/xpcshell/tests/browser/extensions/formautofill/test/unit/head.js -> resource://testing-common/sinon-2.3.2.js, line 8941: ReferenceError: reference to undefined property "iso-8859-8-i"
[task 2018-08-17T13:44:19.487Z] 13:44:19     INFO -  PID 9262 | JavaScript strict warning: resource://testing-common/AddonTestUtils.jsm, line 310: ReferenceError: reference to undefined property "testScope"
[task 2018-08-17T13:44:19.487Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "iso-8859-8-i"" {file: "/builds/worker/workspace/build/tests/xpcshell/tests/browser/extensions/formautofill/test/unit/head.js -> resource://testing-common/sinon-2.3.2.js" line: 8941}]"
[task 2018-08-17T13:44:19.488Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "testScope"" {file: "resource://testing-common/AddonTestUtils.jsm" line: 310}]"
[task 2018-08-17T13:44:19.489Z] 13:44:19     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2018-08-17T13:44:19.489Z] 13:44:19     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2018-08-17T13:44:19.490Z] 13:44:19     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2018-08-17T13:44:19.490Z] 13:44:19     INFO -  running event loop
[task 2018-08-17T13:44:19.490Z] 13:44:19     INFO -  browser/extensions/formautofill/test/unit/heuristics/test_basic.js | Starting head_initialize
[task 2018-08-17T13:44:19.491Z] 13:44:19     INFO -  (xpcshell/head.js) | test head_initialize pending (2)
[task 2018-08-17T13:44:19.492Z] 13:44:19     INFO -  PID 9262 | 1534513456509	addons.manager	DEBUG	Application has been upgraded
[task 2018-08-17T13:44:19.492Z] 13:44:19     INFO -  PID 9262 | 1534513456552	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider", "XPIInternal"]
[task 2018-08-17T13:44:19.493Z] 13:44:19     INFO -  PID 9262 | 1534513456563	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"]
[task 2018-08-17T13:44:19.493Z] 13:44:19     INFO -  PID 9262 | 1534513456578	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/GMPProvider.jsm
[task 2018-08-17T13:44:19.494Z] 13:44:19     INFO -  PID 9262 | 1534513456584	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/PluginProvider.jsm
[task 2018-08-17T13:44:19.494Z] 13:44:19     INFO -  PID 9262 | 1534513456586	addons.manager	DEBUG	Starting provider: XPIProvider
[task 2018-08-17T13:44:19.506Z] 13:44:19     INFO -  PID 9262 | 1534513456587	addons.xpi	DEBUG	startup
[task 2018-08-17T13:44:19.507Z] 13:44:19     INFO -  PID 9262 | 1534513456588	addons.xpi	WARN	List of valid built-in add-ons could not be parsed.: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: startup :: line 2093"  data: no] Stack trace: startup()@resource://gre/modules/addons/XPIProvider.jsm:2093
[task 2018-08-17T13:44:19.508Z] 13:44:19     INFO -  PID 9262 | callProvider()@resource://gre/modules/AddonManager.jsm:206
[task 2018-08-17T13:44:19.508Z] 13:44:19     INFO -  PID 9262 | _startProvider()@resource://gre/modules/AddonManager.jsm:654
[task 2018-08-17T13:44:19.509Z] 13:44:19     INFO -  PID 9262 | startup()@resource://gre/modules/AddonManager.jsm:813
[task 2018-08-17T13:44:19.510Z] 13:44:19     INFO -  PID 9262 | startup()@resource://gre/modules/AddonManager.jsm:2808
[task 2018-08-17T13:44:19.511Z] 13:44:19     INFO -  PID 9262 | observe()@jar:file:///builds/worker/workspace/build/application/firefox/omni.ja!/components/addonManager.js:66
[task 2018-08-17T13:44:19.512Z] 13:44:19     INFO -  PID 9262 | promiseStartupManager()@resource://testing-common/AddonTestUtils.jsm:773
[task 2018-08-17T13:44:19.514Z] 13:44:19     INFO -  PID 9262 | loadExtension()@/builds/worker/workspace/build/tests/xpcshell/tests/browser/extensions/formautofill/test/unit/head.js:42
[task 2018-08-17T13:44:19.515Z] 13:44:19     INFO -  PID 9262 | head_initialize()@/builds/worker/workspace/build/tests/xpcshell/tests/browser/extensions/formautofill/test/unit/head.js:223
[task 2018-08-17T13:44:19.516Z] 13:44:19     INFO -  PID 9262 | run_next_test/_run_next_test/<()@/builds/worker/workspace/build/tests/xpcshell/head.js:1441
[task 2018-08-17T13:44:19.517Z] 13:44:19     INFO -  PID 9262 | _run_next_test()@/builds/worker/workspace/build/tests/xpcshell/head.js:1441
[task 2018-08-17T13:44:19.518Z] 13:44:19     INFO -  PID 9262 | run()@/builds/worker/workspace/build/tests/xpcshell/head.js:692
[task 2018-08-17T13:44:19.521Z] 13:44:19     INFO -  PID 9262 | _do_main()@/builds/worker/workspace/build/tests/xpcshell/head.js:219
[task 2018-08-17T13:44:19.522Z] 13:44:19     INFO -  PID 9262 | _execute_test()@/builds/worker/workspace/build/tests/xpcshell/head.js:533
[task 2018-08-17T13:44:19.522Z] 13:44:19     INFO -  PID 9262 | -e:1
[task 2018-08-17T13:44:19.523Z] 13:44:19     INFO -  PID 9262 | 1534513456601	addons.xpi	INFO	SystemAddonLocation directory is missing
[task 2018-08-17T13:44:19.524Z] 13:44:19     INFO -  PID 9262 | 1534513456637	addons.xpi	INFO	Removing all system add-on upgrades.
[task 2018-08-17T13:44:19.525Z] 13:44:19     INFO -  PID 9262 | 1534513456641	addons.xpi	DEBUG	checkForChanges
[task 2018-08-17T13:44:19.526Z] 13:44:19     INFO -  PID 9262 | 1534513456642	addons.xpi	DEBUG	Loaded add-on state: ${}
[task 2018-08-17T13:44:19.527Z] 13:44:19     INFO -  PID 9262 | 1534513456644	addons.xpi	DEBUG	scanForChanges changed: false, state: {}
[task 2018-08-17T13:44:19.528Z] 13:44:19     INFO -  PID 9262 | 1534513456647	addons.xpi	DEBUG	Empty XPI database, setting schema version preference to 27
[task 2018-08-17T13:44:19.529Z] 13:44:19     INFO -  PID 9262 | 1534513456648	addons.xpi	DEBUG	No changes found
[task 2018-08-17T13:44:19.536Z] 13:44:19     INFO -  PID 9262 | 1534513456676	addons.manager	DEBUG	Registering shutdown blocker for XPIProvider
[task 2018-08-17T13:44:19.537Z] 13:44:19     INFO -  PID 9262 | 1534513456676	addons.manager	DEBUG	Provider finished startup: XPIProvider
[task 2018-08-17T13:44:19.538Z] 13:44:19     INFO -  PID 9262 | 1534513456677	addons.manager	DEBUG	Starting provider: LightweightThemeManager
[task 2018-08-17T13:44:19.539Z] 13:44:19     INFO -  PID 9262 | 1534513456677	addons.manager	DEBUG	Registering shutdown blocker for LightweightThemeManager
[task 2018-08-17T13:44:19.539Z] 13:44:19     INFO -  PID 9262 | 1534513456678	addons.manager	DEBUG	Provider finished startup: LightweightThemeManager
[task 2018-08-17T13:44:19.540Z] 13:44:19     INFO -  PID 9262 | 1534513456680	addons.manager	DEBUG	Starting provider: GMPProvider
[task 2018-08-17T13:44:19.541Z] 13:44:19     INFO -  PID 9262 | 1534513456685	addons.manager	DEBUG	Registering shutdown blocker for GMPProvider
[task 2018-08-17T13:44:19.542Z] 13:44:19     INFO -  PID 9262 | 1534513456686	addons.manager	DEBUG	Provider finished startup: GMPProvider
[task 2018-08-17T13:44:19.543Z] 13:44:19     INFO -  PID 9262 | 1534513456686	addons.manager	DEBUG	Starting provider: PluginProvider
[task 2018-08-17T13:44:19.543Z] 13:44:19     INFO -  PID 9262 | 1534513456687	addons.manager	DEBUG	Registering shutdown blocker for PluginProvider
[task 2018-08-17T13:44:19.544Z] 13:44:19     INFO -  PID 9262 | 1534513456688	addons.manager	DEBUG	Provider finished startup: PluginProvider
[task 2018-08-17T13:44:19.545Z] 13:44:19     INFO -  PID 9262 | JavaScript strict warning: resource://gre/modules/LightweightThemeManager.jsm, line 772: ReferenceError: reference to undefined property "version"
[task 2018-08-17T13:44:19.546Z] 13:44:19     INFO -  PID 9262 | 1534513456701	addons.manager	DEBUG	Completed startup sequence
[task 2018-08-17T13:44:19.546Z] 13:44:19     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2018-08-17T13:44:19.547Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (info) 1534513456509	addons.manager	DEBUG	Application has been upgraded"
[task 2018-08-17T13:44:19.548Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (info) 1534513456552	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider", "XPIInternal"]"
[task 2018-08-17T13:44:19.557Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (info) 1534513456563	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"]"
[task 2018-08-17T13:44:19.558Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (info) 1534513456578	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/GMPProvider.jsm"
[task 2018-08-17T13:44:19.559Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (info) 1534513456584	addons.manager	DEBUG	Loaded provider scope for resource://gre/modules/addons/PluginProvider.jsm"
[task 2018-08-17T13:44:19.560Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (info) 1534513456586	addons.manager	DEBUG	Starting provider: XPIProvider"
[task 2018-08-17T13:44:19.561Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (info) 1534513456587	addons.xpi	DEBUG	startup"
[task 2018-08-17T13:44:19.563Z] 13:44:19     INFO -  "CONSOLE_MESSAGE: (info) 1534513456588	addons.xpi	WARN	List of valid built-in add-ons could not be parsed.: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: startup :: line 2093"  data: no] Stack trace: startup()@resource://gre/modules/addons/XPIProvider.jsm:2093
[task 2018-08-17T13:44:19.564Z] 13:44:19     INFO -  callProvider()@resource://gre/modules/AddonManager.jsm:206
[task 2018-08-17T13:44:19.565Z] 13:44:19     INFO -  _startProvider()@resource://gre/modules/AddonManager.jsm:654
[task 2018-08-17T13:44:19.566Z] 13:44:19     INFO -  startup()@resource://gre/modules/AddonManager.jsm:813
[task 2018-08-17T13:44:19.567Z] 13:44:19     INFO -  startup()@resource://gre/modules/AddonManager.jsm:2808
[task 2018-08-17T13:44:19.568Z] 13:44:19     INFO -  observe()@jar:file:///builds/worker/workspace/build/application/firefox/omni.ja!/components/addonManager.js:66
[task 2018-08-17T13:44:19.569Z] 13:44:19     INFO -  promiseStartupManager()@resource://testing-common/AddonTestUtils.jsm:773
[task 2018-08-17T13:44:19.570Z] 13:44:19     INFO -  loadExtension()@/builds/worker/workspace/build/tests/xpcshell/tests/browser/extensions/formautofill/test/unit/head.js:42
[task 2018-08-17T13:44:19.571Z] 13:44:19     INFO -  head_initialize()@/builds/worker/workspace/build/tests/xpcshell/tests/browser/extensions/formautofill/test/unit/head.js:223
[task 2018-08-17T13:44:19.572Z] 13:44:19     INFO -  run_next_test/_run_next_test/<()@/builds/worker/workspace/build/tests/xpcshell/head.js:1441
[task 2018-08-17T13:44:19.573Z] 13:44:19     INFO -  _run_next_test()@/builds/worker/workspace/build/tests/xpcshell/head.js:1441
[task 2018-08-17T13:44:19.574Z] 13:44:19     INFO -  run()@/builds/worker/workspace/build/tests/xpcshell/head.js:692
[task 2018-08-17T13:44:19.575Z] 13:44:19     INFO -  _do_main()@/builds/worker/workspace/build/tests/xpcshell/head.js:219
[task 2018-08-17T13:44:19.576Z] 13:44:19     INFO -  _execute_test()@/builds/worker/workspace/build/tests/xpcshell/head.js:533
[task 2018-08-17T13:44:19.576Z] 13:44:19     INFO -  -e:1"
Flags: needinfo?
(Reporter)

Comment 2

9 months ago
This is a regression from https://bugzilla.mozilla.org/show_bug.cgi?id=1449055
:aswan, Could you have a look at this?
Blocks: 1449055
Flags: needinfo?(aswan)
Summary: Perma xpcshell in browser/extensions/formautofill/test/unit/heuristics/test_basic.js when Gecko 63 merges to Beta on 2018-08-27 → Perma xpcshell in browser/extensions/formautofill/test/unit/heuristics/*.js when Gecko 63 merges to Beta on 2018-08-27
Matt, this blocks today's merge to Beta. Can you please update the patch from kmag's review comments since Andrew is on PTO until next week?
Flags: needinfo?(MattN+bmo)
Looking into this now.
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(MattN+bmo)
Priority: -- → P1
I've tried different permutations of AddonTestUtils.overrideCertDB(), AddonTestUtils.overrideBuiltIns(…), and AddonTestUtils.promiseStartupManager() and haven't been able to get the tests working. The issue is that the resource: don't seem to be setup. It seems like autofill's api.js/onStartup isn't getting called even though the addon-manager logging doesn't seem to indicate a failure installing:

> addons.xpi	DEBUG	Calling bootstrap method install on formautofill@mozilla.org version 1.0"
> addons.xpi	DEBUG	Calling bootstrap method startup on formautofill@mozilla.org version 1.0"

(not sure whether the reference to "bootstrap" above should be ignored).

and registering the upgrade listener (I assume from background.js):
> addons.manager	DEBUG	Registering upgrade listener for formautofill@mozilla.org"

so it seems like the problem is with onStartup not getting called but really I'm just guessing since there is a lot going on that I don't know about.

kmag, it's probably best for you to take this rather than me having to spend hours learning how webextension experiments are supposed to work.
Flags: needinfo?(kmaglione+bmo)
Comment on attachment 9003654 [details]
Bug 1484236: Override cert DB for form autofill xpcshell tests. r=rhelmer

Robert Helmer [:rhelmer] has approved the revision.
Attachment #9003654 - Flags: review+
(Assignee)

Comment 9

9 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/d6eb2c2d5830712ec0632bfec4a1c7c1e7b6cbae
Bug 1484236: Override cert DB for form autofill xpcshell tests. r=rhelmer CLOSED TREE
Thanks. I guess there must have been a race when I tried using overrideCertDB inside of loadExtension like I thought I saw other tests doing in the tree.
Assignee: MattN+bmo → kmaglione+bmo
Flags: needinfo?(kmaglione+bmo)
(Assignee)

Comment 11

9 months ago
(In reply to Matthew N. [:MattN] (PM if requests are blocking you) from comment #10)
> Thanks. I guess there must have been a race when I tried using
> overrideCertDB inside of loadExtension like I thought I saw other tests
> doing in the tree.

It only works for packaged extensions. We always run tests from packaged builds on automation, so this is never a problem there. Local builds by default run unpackaged, though, so it generally won't help if you're testing locally.

Comment 12

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d6eb2c2d5830
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Attachment #9002252 - Attachment is obsolete: true
Attachment #9002252 - Flags: review?(kmaglione+bmo)
No longer depends on: 1491028
You need to log in before you can comment on or make changes to this bug.