SVG path statement does not display correctly

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: hugovanwoerkomqt, Assigned: alex)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
Attached is a testcase xml file. It has 2 path statements of the letter "r" One
shows it correctly, the other has a red streak attached to it that ought not be
there.
Note: I believe no 'z' is needed at the end to return to the beginning, but: if
you put that in, they both have streaks.
This is from a svg enabled trunk build that I pulled on 5/27, but I think all
svg enabled mozillas show it.
I have made the severity major because it disables the project that generated
the file: it shows lots of characters like that and they are mostly bad.
(Reporter)

Comment 1

17 years ago
Created attachment 85850 [details]
xml file with svg path statements that display(s) incorrectly.

This an xml file that displays 2 'r' s on an svg enabled browser. One has a red
streak to it that doesn't belong. If you add the 'z' at the end of the path
statements to return to the beginning, they both have the streaks.
(Reporter)

Comment 2

17 years ago
Created attachment 85879 [details]
Screen in support of severity=major
(Reporter)

Comment 3

17 years ago
Created attachment 85880 [details]
xml file in bzipped form of attachment 85879 [details]
confirming. This is probably one of the bugs we have when points are too close
together.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

17 years ago
Created attachment 85958 [details]
xml file w/o problem

Attachment is an xml file that avoids the problem by entering all coordinates
with 2 decimal places. It is the same graphic as the previous attachments.
(Assignee)

Comment 6

15 years ago
This now works ok with both libart and gdi+ backends -> Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 7

15 years ago
Probably fixed by bug 182533.
You need to log in before you can comment on or make changes to this bug.