Closed Bug 1484781 Opened 4 years ago Closed 2 years ago

[SUMO User Issue] Consult on 301 and 302 image redirect

Categories

(DevTools :: Netmonitor, enhancement)

61 Branch
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1617852

People

(Reporter: guigs, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

Issue original post: https://support.mozilla.org/sl/questions/1230320

What the user is seeing: They are observing a webpage loading in Firefox Web Developer Tools, and comparing the number of networking requests for an image in a webpage to ARC.

Image file size: 18MB
Observed 302 to 301 redirect of larger size than the requested image

(Screenshots of the requests are in the original support post)

Note for assignee: Thank you for your consult and help. Any info that you need, needinfo: guigs for more info until we get the user on bugzilla :)
Component: Networking: HTTP → Netmonitor
Product: Core → DevTools
Hey there!

So the "issue" is that when I'm inspecting the request flow for an image in the network tab of Firefox Web Developer Tools it seems to me like the Transfered and Size columns are off on the 302 and 301 requests - showing as if the whole image is downloaded on each request instead of it just beeing a small (100B-300B redirect).

there are 3 requests happening for an image:
1. request goes to the image endpoint and passes a reference and width as parameters
the result of this request is a 302 redirect to a /public/[generated_file_name].jpg/png
when inspecting the request headers, it shows that response headers are as expected (100B-300B) and Content-Length is 0
the transfered (and Size) columns in the network tab are however showing the full size of the image (that is actually downloaded only once - at the 3rd request - the sizes of the images differ, but are in range from 10KB to 200KB).

2. request goest to the address provided as location of the 1. request and the response is just a 301 request to another domain for the same path/file
also here the request and response headers are in the size range of a few 100B which is normal, the Content-Length header value is 185, but the transfered and size columns are showing full size of the image

3. the third request is actually getting the photo and there the Content-Length in the headers is the same as file size and it is all as expected here.

I've observed the same behaviour on Windows 7 with Firefox 61.0.2 and also on Ubuntu 16.04 with Firefox 61.0.1 (Both systems and browsers 64bit). When inspecting the same image request in Chrome development tools, the size/transfered values are as I would expect. Similarly also when performing requests with curl or ARC, that is why i'm thinking the bug is in Firefox tools and not the other way arround.

Screenshots of Firefox, Chrome and ARC can be seen in the original post.

If you need an example URL for reproducing the "error" please contact me directly and I will provide it for you privatly.
And for any other info that could be helpful just ask :).

Thanks!

Thanks for the report!

Do you have a simple test case we could use to reproduce the issue on our machines? (can be an online HTML page or a page attached to this bug).

Honza

Flags: needinfo?(flynorc)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1617852
You need to log in before you can comment on or make changes to this bug.