Closed Bug 1484818 Opened 2 years ago Closed 1 year ago

Intermittent devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-05.js | Test timed out -

Categories

(DevTools :: Debugger, defect, P5)

defect

Tracking

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: bhackett1024)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [TV-bf pass:fail] [stockwell disable-recommended])

Attachments

(1 file, 1 obsolete file)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=194882151&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/QvtbihZdRlKaS8d9WnX0wA/runs/0/artifacts/public/logs/live_backing.log

09:47:32     INFO - Buffered messages logged at 09:46:05
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
09:47:32     INFO - Buffered messages logged at 09:46:28
09:47:32     INFO - Console message: [JavaScript Error: "NetworkError when attempting to fetch resource."]
09:47:32     INFO - get@resource://services-settings/remote-settings.js:326:9
09:47:32     INFO - async*getSite@resource://activity-stream/lib/FaviconFeed.jsm:158:25
09:47:32     INFO - async*fetchIcon@resource://activity-stream/lib/FaviconFeed.jsm:132:24
09:47:32     INFO - async*onAction@resource://activity-stream/lib/FaviconFeed.jsm:182:9
09:47:32     INFO - _middleware/</<@resource://activity-stream/lib/Store.jsm:51:11
09:47:32     INFO - Store/this[method]@resource://activity-stream/lib/Store.jsm:29:54
09:47:32     INFO - _requestRichIcon@resource://activity-stream/lib/TopSitesFeed.jsm:457:5
09:47:32     INFO - _fetchIcon@resource://activity-stream/lib/TopSitesFeed.jsm:421:5
09:47:32     INFO - async*getLinksWithDefaults@resource://activity-stream/lib/TopSitesFeed.jsm:326:11
09:47:32     INFO - async*refresh@resource://activity-stream/lib/TopSitesFeed.jsm:349:25
09:47:32     INFO - async*onAction@resource://activity-stream/lib/TopSitesFeed.jsm:649:9
09:47:32     INFO - _middleware/</<@resource://activity-stream/lib/Store.jsm:51:11
09:47:32     INFO - Store/this[method]@resource://activity-stream/lib/Store.jsm:29:54
09:47:32     INFO - init/this.intervalId<@resource://activity-stream/lib/SystemTickFeed.jsm:18:41
09:47:32     INFO - notify@resource://gre/modules/Timer.jsm:42:7
09:47:32     INFO - 
09:47:32     INFO - Buffered messages finished
09:47:32     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_breakpoints-05.js | Test timed out - 
09:47:32     INFO - Removing tab.
09:47:32     INFO - Waiting for event: 'TabClose' on [object XULElement].
09:47:32     INFO - Got event: 'TabClose' on [object XULElement].
09:47:32     INFO - Tab removed and finished closing
09:47:32     INFO - GECKO(1973) | MEMORY STAT | vsize 4938MB | residentFast 890MB | heapAllocated 135MB
09:47:32     INFO - TEST-OK | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_breakpoints-05.js | took 90310ms
Whiteboard: TV-bf pass:fail] → [TV-bf pass:fail]
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INCOMPLETE
Recent failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=210791096&repo=mozilla-inbound&lineNumber=337513:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/devtools-components/arrow.svg."]
03:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/debugger/domain.svg."]
03:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/debugger/folder.svg."]
03:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/debugger/pause.svg."]
03:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/debugger/stepOver.svg."]
03:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/debugger/stepIn.svg."]
03:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/debugger/stepOut.svg."]
03:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/debugger/disable-pausing.svg."]
03:56:36     INFO - Console message: [JavaScript Error: "Security Error: Content at resource://devtools/client/debugger/new/dist/debugger.css may not load or link to chrome://devtools/skin/images/help.svg."]
03:56:36     INFO - Buffered messages finished
03:56:36     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_breakpoints-05.js | Test timed out - 
03:56:36     INFO - Removing tab.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → INCOMPLETE
Duplicate of this bug: 1558048
Summary: Intermittent devtools/client/debugger/new/test/mochitest/browser_dbg_rr_breakpoints-05.js | Test timed out - → Intermittent devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-05.js | Test timed out -

This is permafailing on macosx1014-64-shippable opt since bug 1494796 landed here: https://tinyurl.com/y5mrz6bg
Yulia, could you please take a look over this? Thank you.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=252306141&repo=autoland&lineNumber=1040

Flags: needinfo?(ystartsev)
Regressed by: 1494796

CC brian

Flags: needinfo?(bhackett1024)
Assignee: nobody → bhackett1024
Flags: needinfo?(ystartsev)
Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ea80e7505256
Fix record/replay problems with protocol.js ThreadClient, r=yulia.
Attachment #9073015 - Attachment is obsolete: true
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Regressions: 1561327
Flags: needinfo?(bhackett1024)
See Also: → 1584437
You need to log in before you can comment on or make changes to this bug.