Closed Bug 1484969 Opened 5 years ago Closed 4 years ago

Basic Tracking Protection breaks slideshow on jornaldocarro.estadao.com.br

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 62
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sergiu, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-ads])

User Story

googletagmanager.com
Environment:
Operating system: Windows 10 Pro
Firefox version: Firefox Nightly 63.0a1 (2018-08-20) (64-bit)

Prerequisites:
Enable Basic Tracking Protection

Steps to reproduce:
1. Navigate to: https://jornaldocarro.estadao.com.br/galeria/motos-que-nao-deixaram-saudade/?id=37847
2. Click on the "Next" button in the slideshow.
3. Click on the "Next" button again in the slideshow.

Expected Behavior:
The next image is displayed.

Actual Behavior:
Nothing happens.

Notes:
1. Screenshot attached: http://prntscr.com/kl53b8
This is related to `trackingprotection` breakage #1101005

Looking at the devtools console, here are the blocked resources:

The resource at “https://www.googletagservices.com/tag/js/gpt.js” was blocked because content blocking is enabled.[Learn More] motos-que-nao-deixaram-saudade
The resource at “https://www.googletagmanager.com/gtm.js?id=GTM-NG5W2Q4” was blocked because content blocking is enabled.[Learn More] motos-que-nao-deixaram-saudade

So these are the domains to test:
googletagservices.com
googletagmanager.com

I opened the URL in a fresh browser profile (Firefox Nightly 63, uMatrix installed, normal mode) and loaded the page. After clicking Next in the slideshow, no other photo in the slideshow could be displayed.

I disabled the Spoof Referrer option in uMatrix and then *WHITELISTED*:

-googletagmanager.com

After this, the slideshow worked as expected.
The other resources didn't help.

http://prntscr.com/kl4uy1

googletagmanager.com can be found in the disconnect-blacklist.json, disconnect-entitylist.json and disconnect_mapping.py.

So in conclusion:

googletagmanager.com - Advertising = [tp-ads]
Blocks: tp-breakage
User Story: (updated)
Whiteboard: [tp-ads]
Product: Tech Evangelism → Web Compatibility

The site layout may have changed, as I'm not seeing any "next" buttons at all anymore, even without tracking protection (or in Chrome). The site seems to work for me the same way even in strict mode now.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.