Open Bug 1484977 Opened 2 years ago Updated 15 days ago

Custom tab not working on some devices

Categories

(Firefox for Android :: Custom Tabs, defect, P2)

Firefox 63
ARM
Android
defect

Tracking

()

REOPENED
Tracking Status
firefox-esr68 --- affected
firefox61 --- wontfix
firefox62 - wontfix
firefox63 - wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix

People

(Reporter: sflorean, Assigned: andrei.a.lazar)

Details

(Keywords: regression)

Attachments

(1 file)

Environment: 
Device: Xiaomi Mi4i (Android 5.0.2), Nexus 7 (Android 5.1.1), Huawei MediaPad M2 (Android 5.1.1);
Build: Nightly 63.0a1 (2018-08-20);

Steps to reproduce:
1. Set Firefox as the default browser;
2. Go to Gmail app and perform a short tap on a link;

Expected result:
The link is opened using Firefox Custom tab.

Actual result:
The link is opened in Firefox Beta.

Notes:
Not reproducible with Sony Xperia Z5 Premium (Android 6.0.1), Samsung Galaxy S8+ Android 8.0.0, 	OnePlus 5T (Android 8.1.0).
Also reproducible on Nexus 9(Android 6.0.1).
Summary: Custom tab not working on Android 5 → Custom tab not working on Android 5 & 6
Summary: Custom tab not working on Android 5 & 6 → Custom tab not working on some devices
Is 61 release affected? Can we get a regression range for this?
Flags: needinfo?(sorina.florean)
Tested with devices:
 - Xiaomi Mi4i (Android 5.0.2), 
 - Huawei MediaPad M2 (Android 5.1.1),
 - Nexus 9 (Android 6.0.1).

Hello,

I cannot find a regression range. 

It seems like this issue was reproducible from the first build that used Custom Tab.

Thank you!
Flags: needinfo?(sorina.florean)
Doesn't sound like we need to track this if it's always been broken.
Duplicate of this bug: 1496684
Assignee: nobody → andrei.a.lazar

Marking this P1 per triage today. Would a logcat be useful?

Priority: -- → P1

Sorina, can you try to reproduce this again and include logcat info? Thanks!

Flags: needinfo?(sorina.florean)
Attached file customtabs.txt

Here is the log for the issue. Note that PWA is working fine, I was able to browse and select text and use "Open in Firefox Nightly" option. Let me know if extra information is needed. Thanks!

Flags: needinfo?(sorina.florean)

Sorina, one more try? We think maybe the fix in the duplicate bug may have fixed this now since Petru and Andrei haven't been able to reproduce the issue.

Flags: needinfo?(sorina.florean)

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #9)

Sorina, one more try? We think maybe the fix in the duplicate bug may have
fixed this now since Petru and Andrei haven't been able to reproduce the
issue.

Tested again on the latest Nightly build (67.0a1) and couldn't reproduce the issue. I will close it as worksforme.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(sorina.florean)
Resolution: --- → WORKSFORME

Reproducible with

  • Xiaomi Mi4i (Android 5.0.2)
  • Samsung Galaxy Note 8 (Android 9)
    Build: 67.0b14.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Hi,

I managed to reproduce this issue.

Environment
Device: Samsung Galaxy Tab, Android (5.1.1)
Build: Firefox Beta 67.0b14

Regards,
Diana Rus

Hi! This is reproducible on Release 68.0 build 3 with Samsung Galaxy Tab S3 (Android 8; Tablet).

Downgrading from priority P1 to P2.

Priority: P1 → P2

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Hi, the issue reproduces on Firefox Beta 68.2b2 with Google Pixel 3 XL and Samsung Galaxy Note 9 (Android 8.1.0).
Note: The issue does not reproduce with Sony Xperia Z5 (Android 7.0) and Samsung Galaxy S8+ (Android 8.0.0).

You need to log in before you can comment on or make changes to this bug.